Hello Jeremy,

Trying to install a new nginx appliance to replace V14 as let's encrypt is out of date on the old version. I downloaded the v16  iso. I use hyper V. When you run the install you get to the stage reject CD-ROM FYI this doesn't work under hyper V. So you have to shut the machine down then eject the media. Restarting you get to the login prompt and I realise you can login and start the console. When I go to configure network I get error. Please see screenshot.


Jeremy Davis's picture

Apologies on my slow response to your issue.

For what it's worth, you should have been able to at least attach your screenshot to this post by "editing" the post and uploading the file. It sounds like that isn't working for you for some reason though?! If you re getting some error message when trying to do that, please share the message. (I deleted your other threads where you were trying to upload).

Regarding this issue. Unfortunately, I don't have access to Hyper-V so have never tested it on Hyper-V nor am I able to troubleshoot it. I'm not sure why the "eject" step of the install did not work? I can imagine that the manual "eject" process you described would be a bit of a pain, but at least you can work around that...

Regarding the network issue (which obviously I can't see because you weren't able to upload) but assuming that it's reporting that the network interface is not configured, or something similar, I'd suggest checking the networking config of Hyper-V for the TurnKey VM. My googling suggests that you should first check that you should have selected "Default Switch" during VM creation, otherwise it's possible that your VM will be created in such a way as to not have access to your broader network. If that's not the case, then check the virtual NIC that Hyper-V is presenting. Unless you are already using it, perhaps try configuring the "legacy" vNIC.

I hope that is of some use to you.

Hello Jeremy, I cannot upload an image when replying no option. And no option for edit the original post. Turnkey is worked flawlessly with hyper V until now. I tried a legacy NIC didnt make any difference. The error message in the screenshot relates python with various line numbers.

I just noticed that to edit the post there is a tab in the top left corner. Very odd because the screenshot is attached to the original post.

Jeremy Davis's picture

Yes, I can confirm that the file is indeed attached. It's weird that it doesn't show even for me logged in as Admin. But if I go in and "edit" your post, I can definitely see it?! I wonder what's going on there...?!?

[edit] I added your image to your first post. It seems that although the attachment doesn't show, the file has been uploaded to the server, and it can be embedded once it's been uploaded. It's a bit of a PITA and it's far from a clean workaround, but I guess that it's a workaround of sorts.

Re the error you got, IIRC that error occurs when no network interface is configured. We did fix the issue in a newer release of Confconsole (which newer appliances have pre-installed), but we didn't rebuild the first few apps that have that version of Confconsole (not yet anyway...).

In trying to resolve my Nginx problem on the other thread I just tested and install of V16 on proxmox and you get the same problem with the network as you do on hyper V. Described above. Any idea on this might solve the other issue ?

Jeremy Davis's picture

Until we discovered the bug and fixed it, the first few v16.0 appliances we released would do this (i.e. would throw a stacktrace) if the network was not configured. The more recently released appliances and all of the new v16.1 builds (in progress) include the fixed version. I haven't announced the new builds yet or updated their relevant appliance pages and download links, but as of Monday, there are about 30 updated apps available on the mirror (and via Proxmox).

It's probably going to be a pain without networking, but the latest version of Confconsole could be downloaded, copied across and manually installed.

As for the specifics, if networking isn't working with LXC containers on Proxmox, I suggest that you double check that you have configured it correctly. As I noted above, the stacktrace occurs in Confconsole when no valid networking is configured - so if you configure it right, you shouldn't get the stacktrace. Using DHCP is fine for Desktop type VMs/Containers, but really for a server, you'll want to set a static IP. (rather than within the guest). You can use DHCP on the host then configure static internally, but for LXC, I recommend setting up LXC container servers with a static IP right from the get go. See my example below:

With config like that (assuming that the container network interface config is tailored to the broader network config - e.g. in my case, I have a /24 subnet) it should "just work". If you are unclear on subnets the wikipedia page is good for background and I came across a cool cheatsheet.

Hopefully that helps...

Hello Jeremy, thanks for reply. I managed to fix a problem on hyper V and Proxmox. I notice that it was caused if the appliance could not contact DHCP when it was set up.

So I installed the appliance with a fixed IP address on network with access to dhcp server. Then switch to the other network with a static MAC address and I now have the appliance running correctly. I restored from turnkey hub and the certificates were restored as expected.
So now on the latest version.

Jeremy Davis's picture

Great work. Glad you've got it sorted.

Hopefully an appliance with a newer version of Confconsole should have assisted in diagnosing that problem?!

Regardless, (as I'm sure you're probably already aware) using a static IP for a server is ideally what you want. The easiest way to do that is setting a static IP via the host (in the case of LXC on Proxmox) or on the guest after firstboot. Although it's also possible to do that via DHCP (e.g. if using static MAC via ARP tables).

Add new comment