Armin Weinmann's picture

please excuse my perhaps stupid questions, but I just can't get any further at the moment. First of all about sending mail: I start : confconsole -> Mail relaying -> Mail relay -> Custom Then I enter the access data (host, port, login, password) and after I have pressed Enter a message appears: SMTP connection test successfull Ready to configure Postfix If I then go to this input mask again, my data is gone. What am I doing wrong, where do I continue afterwards? With Letsencrypt I don't have the possibility to enter my data, DNS provider, API key etc.. Is there a tutorial somewhere? Many thanks in advance Armin

Jeremy Davis's picture

Hi Armin, apologies on my slow response. It's not a stupid question, if you're having issues, it's good for us to be aware of and I really appreciate your feedback.

I've run through both the Mail relay config and the Let's Encrypt DNS setup and both "just worked" for me. I started creating a step-by-step walk through to demonstrate but juggling my other responsibilities has meant that it's taking longer to complete that I had hoped. So I figured should just reply to you now (and I'll complete the walk through ASAP and put it in the docs).

And actually, it's occurred to me that I'm not sure what TurnKey version you are running (currently the appliances are a mix of v17.x & v18.x - we're still working through the v18.x upgrades - hopefully we can get them all updated soon).

So just to confirm, which appliance are you using and which version? Hopefully it's one of the v18.x ones (we've made some significant improvements in v18.x).

Regarding your experience with the Confconsole Mail Relay plugin, I can confirm that your experience (i.e .config gone when you go back in) is "expected". If the test succeeds, then it should be configured correctly (it tests access to the SMTP relay using the credentials that you included). However, looking at it, I can see how you got a bit confused and thought that it didn't work properly as it does not show your config. FWIW it should be only cosmetic, but I've opened an issue regarding that. I agree that having it display the config you added (rather than being blank) it would be completely clear that it worked. It would also make adjustments easier (especially if the test fails). Bottom line your config should be fine, but I will look at improving it at some point (soon hopefully).

Regarding the Let's Encrypt - DNS01 Confconsole plugin, it'd be good to know whether you are running v18.0 or not and which appliance. That is because there was a pretty serious bug in it in the early v18.0 releases. It has since been fixed, but if you have the broken version, you'll need to update confconsole to get that version (once we've finished getting all pass to v18.0, we'll probably look at a v18.1 update for those).

So please double check which version you've got and whether there is a newer version available. I.e. first run 'apt update', then 'apt policy confconsole'. If you are on v18.0 and have the latest version, then it should return this:

  Installed: 2.1.3
  Candidate: 2.1.3
  Version table:
 *** 2.1.3 999
        999 bookworm/main amd64 Packages
        100 /var/lib/dpkg/status

If you are on v18.0 and the "Installed" version isn't '2.1.3', then please update it.

I'll try to get the walkthrough done, but I really want to keep the momentum going with the v18.0 updates so we can get those finalized ASAP.

Armin Weinmann's picture

Hi Jeremy, now it's up to me to say sorry for my VERY late answer. The daily madness ...

Your question if i'm using 17.x or 18.x was the solution. I tested with the bugzilla VM that is on 17.1. After I've read your comment I tested with the Dokuwiki VM which is on 18.0. First try was also not successfull but after a

apt-get --fix-missing update && apt-get -y upgrade && apt-get -y dist-upgrade && apt -y autoremove && apt-get autoclean && checkrestart

I was able to get a letsencrypt certificate successfully.

Is there a way to get this also on 17.x? It my be a bumpy way...

Thanks a lot


Jeremy Davis's picture

Glad to hear that you got the v18.0 Dokuwiki appliance working. Soon after we've finished the v18.0 release, I hope to rebuild the library (or at least the older ones such as Dokuwiki) so that that new users won't have to jump through those hoops to get it working.

As for v17.x there is a newer Confconsole release v2.1.0 that should work. It is packaged, but unfortunately isn't available via the apt repo. So you'll need to manually download and install that like this:

apt install ./confconsole_2.1.0+3+gf70719e_all.deb

Hopefully that works. Please let me know if it doesn't and I'll see what I can do...

Armin Weinmann's picture

Hi Jeremy,

I've tested the 2.1.0 with a fresh install of the bugzilla appliance. But when I tried to get the certificate I receive the following error messages:

  +--------------------Caught exception----------------------+
  ¦                                                          ¦
  ¦ Traceback (most recent call last):                       ¦
  ¦   File "/usr/bin/confconsole", line 719, in loop         ¦
  ¦     new_dialog = method()                                ¦
  ¦   File "/usr/lib/confconsole/", line 121, in    ¦
  ¦ run                                                      ¦
  ¦     ret: Optional[str] =               ¦
  ¦   File                                                   ¦
  ¦ "/usr/lib/confconsole/plugins.d/Lets_Encrypt/get_certifi ¦
  ¦", line 152, in run                               ¦
  ¦     config = dns_01.load_config()                        ¦
  ¦ AttributeError: 'NoneType' object has no attribute       ¦
  ¦ 'load_config'                                            ¦
  ¦                                                          ¦
  ¦                                                          ¦
  ¦                                                          ¦


Can you see what causes the problem? Which information is needed to help?





Add new comment