Steve's picture

Hi,

Can someone please help. I am able to boot up the appliance and can access Web Shell, Webmin, Adminer and SSH/SFTP. I can not access NextCloud cause of the Trusted domains.

 

I have tried many types of commands but i am just not winning.

 

nextcloud.occ config:system:set trusted_domains 2 --value=exampledomain.com

nano /var/www/html/nextcloud/config/config.php

 

Please any help will be greatly appriciated. I am new to Linux so please dont be hard on me. Im trying to learn

 

Thanks 

 

 

 

 

Forum: 
Steve's picture

Hi

 

I connected to the virtual applinace and made changes to the config file manually and its working. Tried to delete the post but i can not

 

 

Jeremy Davis's picture

Glad to hear that you managed to work around your issue, although the firstboot inithooks should have added the domain you selected at firstboot to the "trusted domains"?! So if that didn't work, then perhaps there is a bug?!

Another possibility is that comes to mind is that the recent issue with MariaDB caused the issue? Although TBH, I'm not sure that's it as you state that Adminer (and Nextcloud) were working, so that seems unlikely?!

emiy's picture

hello  .. i do not now where the config.php  file is in  this turnkeydistribution   ..  can  some admin  update the top post withthe solution on  adding  a new trusted domain ..  so  people  are not being  tricked to search a mising  solution  on the top  search  results. 
Jeremy Davis's picture

It should be '/var/www/nextcloud/config/config.php'. If you can't find it there, please try running the following from a SSH session:

find /var/www -type f -name config.php

Also FWIW, if you set it correctly on firstboot, then it should "just work" so you should only need to change it if you change the domain that you host it from.

Add new comment