Dan Kruitz's picture

I've set up and logged in as AdminUser and cannot create new webs on the new TWiki appliance.  Had been using the "old" one for a couple of months with success.  The new one is a fresh install.  Any ideas?  I get the following error message  - not sure if it's related to the appliance, or TWiki itself.

"Access check on Main.WebHome failed. Action "CHANGE": access not allowed on root."

Thanks for looking,

Jeremy Davis's picture

It sounds like the folder where it is trying to do something is owned by root rather than the webserver account. I'm not familar with the appliance but if you can find the folder where Twiki resides and chown it to the user www-data (the webserver user account) that hopefully will fix the issue. If that doesn't work then try giving it 777 permissions (which is allow anyone to do anything) and that should fix it for sure (but is potentially a security risk).

Dan Kruitz's picture

I've not had a chance to get back to this problem until lately.  I've re-installed the TWiki with the latest download in case something was changed with it.  No idea where the TWiki install is located.  Still cannot add webs to the TWiki so it appears the appliance is not built correctly.  Would be happy to work with someone on testing with it.

Jeremy Davis's picture

And I think that it definately classes as an appliance bug. I'm happy to have a look and help you (and the TKL devs) work out a resolution. Unfortunately I'm pretty snowed under at the moment. In the meantime perhaps log a bug on the TKL Bugtracker. You can just give a brief outline of the problem and link back to this forum if you'd like.

Nigel Watson's picture

I have just experienced the same problem -- did you have any luck in finding a resolution or a work around?

Glen's picture

This is still a problem. I worked around it by commenting out the code that does the check so I could create the new web then restoring the file.

Jeremy Davis's picture

Should be something like this:

chown -R www-data:www-data /var/www/twiki

Does that resolve the issue?

Glen's picture

I checked those permissions, but they were all fine. Just in case I'd missed something, I ran the chown but it didn't help. Looking at where the error occurred in the code, it is failing the check at /var/www/twiki/lib/TWiki/Access.pm line 196. That's the section I commented out to bypass the check and create the new web. :-)

Jeremy Davis's picture

Obviously it's a Twiki internal permission issue then, nothing to do with Linux file permissions as I guessed...

Thanks for the further details, at least others can easily apply your workaround now.

Dan Kruitz's picture

OK, I just tried that, and for me it was line 195 through 201 that had to be commented out.  from the if through  the 2nd { after the return 0;

Thanks much!

Dan Kruitz's picture

re: chown....

Still getting "Access check on Main.WebHome failed. Action "CHANGE": access not allowed on root. "

Have you tried the actual appliance itself?  My linux skills are limited and I (and other apparently) are stumped by this.  I can't upgrade to the new shiny version until web creation is fixed.  :-(

Dan Kruitz's picture

Note, I even tried the chmod -R 777 twiki from /var/lib with no luck.

Jeremy Davis's picture

See his post above.

DavidC's picture

I went to the http://yoursite/bin/configure page

No password I tried worked here so I followed the instructions under the Notes to edit the var/www/twiki/lib/LocalSite.cfg file and deleted the line called $TWiki::cfg{Password}

Then going back to the configure page above I was prompted to create a new password. (Be sure to click next to go to the next screen to save the new password).

Then went to the page http://yoursite/bin/view/Main/TWikiAdminUser page.

From here saw a link to login as the internal Twiki administrator, and on the next screen logged in as admin (and not AdminUser) and used the new password.

From there was able to go to here to add a new Web:


Hope this helps someone else.

Alon Swartz's picture

Thanks for reporting the bug folks, and sorry it took so long to be squashed. I updated the bug report with the following:

As always, thanks for reporting the issue. I've committed a fix which will be included
in the upcoming release. The fix is actually quite simple, and not sure how the bug 
got through our testing.

To fix this issue in currently deployed appliances, add the AdminUser to the 


- * Set GROUP = TWikiAdminUser
+ * Set GROUP = TWikiAdminUser AdminUser

This not only fixes the issue of creating new Webs, but also other actions that require TWikiAdminGroup privileges.

Tom's picture

During Registering a new user:

1. Access check on UserForm failed. Action "VIEW": access not allowed on web. but... I receive email confirmation.

The user looks like this TestTest? - TestTest?

Any help?

Tom's picture


Action "CHANGE": 

Add new comment