TurnKey Linux Virtual Appliance Library

Accessing Turnkey WordPress server when port 80 is blocked

imchrisd's picture

I set up a Turnkey Linux WordPress appliance as a sandbox for development.  I'd like my clients to be able to see what I’m working on but unfortunately my ISP blocks port 80.

So I set port forwarding on my router to forward port 8081 (WAN) to port 80 (LAN).  This works fine from outside for my main site using http://mywebaddress.com:8081

But I created a sub site at (LAN)  That works fine from inside but when I try to access from outside using http://mywebaddress.com:8081/newsite I get a timeout error. 

Is this the right syntax?

     Thanks in advance. - Chris

Jeremy Davis's picture

Hmm that sounds strange

The format you use should work and I don't really understand why http://mywebaddress.com:8081
works but http://mywebaddress.com:8081/newsite doesn't. Especially considering it seems to work inside your LAN but not from outside.

Not sure whether it will help in your scenario or not but some dynamic DNS providers (many listed and discussed in this thread) allow to redirect ports at the DNS level. So instead of requiring http://mywebaddress.com:8081 you can just use http://mywebaddress.com from outside and it will resolve to the desired port. As I say, I'm not sure whether that will solve your issue, but it may? Also another thing you could try is setting up the server to listen on 8081 (rather than 80) that way hopefully you will at least get consistent results from inside and outside your LAN.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)