Drew Ruggles's picture

Round Six:

1. Trashed everything

2. Installed TKL-LAMP to bare metal via Unetbootin LiveUSB

3. Added Drew as a user

4. Installed Samba via apt-get in Webmin

5. Went to Webmin modules and tried to install webmin-samba. Boom! Only works under webmin 1.570

6. Went all CLI all over that: apt-get install webmin-samba

root@antilles /home/Drew# apt-get install webmin-samba
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 46 not upgraded.
Need to get 257kB of archives.
After this operation, 266kB of additional disk space will be used.
Get:1 http://archive.turnkeylinux.org/ubuntu/ lucid/main webmin-samba 1.520-turnkey+4+ga5a493f [257kB]
Fetched 257kB in 0s (307kB/s)
[master e19e435] saving uncommitted changes in /etc prior to apt run
 15 files changed, 16 insertions(+), 3 deletions(-)
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously deselected package webmin-samba.
(Reading database ... 29553 files and directories currently installed.)
Unpacking webmin-samba (from .../webmin-samba_1.520-turnkey+4+ga5a493f_i386.deb) ...
Setting up webmin-samba (1.520-turnkey+4+ga5a493f) ...
Installed Samba Windows File Sharing in /usr/share/webmin/samba (1464 kb)

[master fbc352c] committing changes in /etc after apt run
 4 files changed, 122 insertions(+), 67 deletions(-)
 create mode 100644 webmin/samba/config

Looks good, right? Go to my servers menu, no Samba server.

7. More CLI


Still no menu item.

OK, what's the procedure for adding Webmin modules so that they *actually* appear in the Webmin interface?



Jeremy Davis's picture

Far out mate you don't give up easily do you!

TBH I have no idea why your Samba module is not displaying.AFAIK it should and I have installed other Webmin modules via apt-get and they have appeared in the interface immediately (IIRC correctly Samba should appear under Servers).

I'll have a quick look for you when I get home. The only thing that occurred to me is that you didn't mention installing Samba, but on reread of your post I see that you did that earlier. As you installed with apt-get it should be irrellevant whether it is via Webmin or commandline.

Hopefully I'll have time tonight to have a quick play and see if I can get it to work as expected and get back to you.

Eric (tssgery)'s picture


I ran into a similar error trying to install Webmin addons.


Somewhere in the Webmin interface is an option to upgrade webmin, I did that (from the webmin UI and NOT from the cli) and can now install any webmin module without difficulty.

Jeremy Davis's picture

AFAIK the TKLBAM module is only compatible with 1.520 (although I think theoretically it should work). All the other 1.520 modules are precompiled and in the TKL repo anyway. I have installed many of them with apt-get and have had no trouble getting them to appear. It has only been once Webmin is upgraded that the problems start (in my experience anyway).

Drew Ruggles's picture

Started all over (not now, earlier) from a clean slate. No custom partitions, no LVM, just "use entire disk" when installing TKL LAMP. It gave me just 2 partitions this time -- FYI, I really think there is a bug in the Debian installer when any other setting is used -- Linux on ext4 and Linux Swap on an Extended Partition. Nice!

I made sure to *not* upgrade Webmin to avoid the pitfalls of losing it again, and there being no apparent backup of it in the TKL repositories...

I know this is suppose to show up in the Servers menu, but it's definitely not there. So then I stopped looking at and worked on my vbox install...


Jeremy Davis's picture

But I just tested this on a VM then and it worked for me. I was already logged into Webmin, on the server page (only SSH Server there). Then ran:

apt-get update
apt-get install samba webmin-samba

and refreshed the page (just hit reload) and 'Samba Windows File Sharing' showed up, so not sure why it isn't working for you? Perhaps it's a browser caching issue? (Although usually browsers don't cache SSL/https).

Drew Ruggles's picture

I did manage to get a good install of Virtualbox up, and installed a Lubuntu client. Then I installed and configured phpVirtualbox, and all is working as advertised. Haven't gotten the Samba server up and running, yet -- but I'm sure I can get it. I have a Ghost image of an XP workstation that is next up in the Vbox install. I'll set up a separate post, outlining the steps I took to get TKL-LAMP on bare metal up and running, and the vbox installation steps (tip: carefully walking through the command line interface -- vboxmanage -- section in the official manual is the only way I found this to work.)

Just wanted to let Jeremy know that all his advice has paid off, and I now have a good server w VM up and running, and thank him for all his patience working through this.


Jeremy Davis's picture

Glad to hear that after all your troubles you have finally had some progress!

And your most welcome for my help. I'm glad that I could be of assistance to you and that you were finally able to have some progess.

Look forward to your write up when you are all done.

Drew Ruggles's picture

Anyone know how to get the PPTP-Server module to appear in Webmin?

I installed via Command Line:

root@antilles /home/Drew# apt-get install webmin-pptp-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
The following NEW packages will be installed:
  webmin-pptp-client webmin-pptp-server
0 upgraded, 2 newly installed, 0 to remove and 51 not upgraded.
Need to get 58.4kB of archives.
After this operation, 73.7kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://archive.turnkeylinux.org/ubuntu/ lucid/main webmin-pptp-client 1.520-turnkey+4+ga5a493f [24.9kB]
Get:2 http://archive.turnkeylinux.org/ubuntu/ lucid/main webmin-pptp-server 1.520-turnkey+4+ga5a493f [33.4kB]
Fetched 58.4kB in 0s (98.7kB/s)
[master d597ae5] saving uncommitted changes in /etc prior to apt run
 20 files changed, 1565 insertions(+), 6 deletions(-)
 rewrite webmin/system-status/info (100%)
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously deselected package webmin-pptp-client.
(Reading database ... 92202 files and directories currently installed.)
Unpacking webmin-pptp-client (from .../webmin-pptp-client_1.520-turnkey+4+ga5a493f_i386.deb) ...
Selecting previously deselected package webmin-pptp-server.
Unpacking webmin-pptp-server (from .../webmin-pptp-server_1.520-turnkey+4+ga5a493f_i386.deb) ...
Setting up webmin-pptp-client (1.520-turnkey+4+ga5a493f) ...
Installed PPTP VPN Client in /usr/share/webmin/pptp-client (176 kb)

Setting up webmin-pptp-server (1.520-turnkey+4+ga5a493f) ...
Installed PPTP VPN Server in /usr/share/webmin/pptp-server (272 kb)

[master 88941af] committing changes in /etc after apt run
 5 files changed, 536 insertions(+), 483 deletions(-)
 create mode 100644 webmin/pptp-client/config
 create mode 100644 webmin/pptp-server/config

...so I would expect it to show up under Networking, but no luck. Any thoughts?



Drew Ruggles's picture

I finally figured this out... OK, if I'm logged in to Webmin as Drew, and try to install a Webmin module from the Webmin Module Install page, it will barf because TKL is using Webmin 1.520, not 1.570. However, if I use the Command Line Interface:

apt-get install webmin-{module_name}

it will install a 1.520 TKL version of the module. However, it wasn't showing up in my Webmin UI.

Here's the deal -- when I used the apt-get install command, I had to be logged in as root, otherwise I had permissions issues with trying to install as Drew (is there a setting where I can or should allow Drew to install...?). So, being logged in to the Webmin UI as Drew, I did not see the new modules. However, if I logged out of Webmin, and logged back in as root, Voila! All the modules I installed have appeared. I'm guessing I need to change my permissions somehow, but wanted to get an opinion on this.



Jeremy Davis's picture

By default, standard user accounts can't make any system wide changes, only change local user settings (which are generally found in hidden folders in your home dir - usually /home/username). To make system wide changes from your standard user account you will want to install an app called 'sudo' (a sort of acronym for Super User DO). There is also another handy GUI sudo tool called gksudo (for launching GUI apps with super user priveleges). So as root user:

apt-get update
apt-get install sudo gksudo

Also you'll need to add your user 'Drew' to the sudousers group.

Then you can do stuff that a root user can do (ie stuff a normal user can't do) by appending 'sudo' to the start of any of those commands eg to install package xyz, instead of

apt-get install xyz

you'd do

sudo apt-get install xyz

It will then ask for your user password ('Drew' password) and will allow you to use sudo commands for 15 minutes idle (after which time it will ask for your password again).

As for the specifics for Webmin, TBH I'm not sure really but I suspect that it is configurable through Webmin. Although you could just use Webmin as root user if you wanted (you could be logged in locally as Drew, but log in to Webmin via your browser as root).

Jeremy Davis's picture

Thanks for your input.

However, this is the support forums of TurnKey Linux and we package Webmin ourselves. One of the reason we do that is so that only the bare minimum relevant modules need to be installed. Additional modules can be installed as needed/desired.

But because we package ourselves, sometimes our version is a little behind what Webmin themselves have available. When that happens often the latest plugins from Webmin won't work with the version of Webmin on TurnKey.

That's why we recommend you install using apt. Then it will work, no problems! :)

Add new comment