TurnKey Linux Virtual Appliance Library

Can't Log Into Wordpress Appliance

allpoints's picture

Having a little trouble logging into my new Turnkey Wordpress appliance. Just the Wordpress page.

 

I can log in everywhere else, but this WP thing completely destroys the usefulness of the appliance.

 

I've changed the password in PHPMyAdmin, and rehashed it - no joy.

 

Halphalp!

 

Thanks.

allpoints's picture

I just uninstalled the

I just uninstalled the appliance. No more problems.

 

 

 

 

Thanks.

Liraz Siri's picture

Hmmm. That's a somewhat

Hmmm. That's a somewhat roundabout way of solving your login problem...

  1. What build version of TurnKey were you using? The ISO, the VM, EC2...

2) Did you have console access on the machine? A configuration utility of sorts runs on first boot to help you set passwords.

Guest's picture

>Hmmm. That's a somewhat

>Hmmm. That's a somewhat roundabout way of solving your login problem...

Aye. But you have to admit it was expedient and 100% effective at eliminating the problem...

 

>What build version of TurnKey were you using? The ISO, the VM, EC2...

The latest VM. Installed on VBox with Turnkey's excellent OVF file, in a Solaris 11 exclusive IP zone.

The installation and setup proceeded normally, just like The Turnkey Drupal appliance I have bridged to a vnic in another zone.

 

>2) Did you have console access on the machine? A configuration utility of sorts runs on first boot to help you set passwords.

Yes, both natively (VBox vrdpe) and through Shell In A Box. I also had access through Webmin and PHPMyAdmin.

I was able to set passwords at installation according to my longstanding scheme, and I was able to access every other password-protected function of the appliance - just not the one that matters most in this particular app. :/

 

After a couple hours of passwrd, PHPMyAdmin, and Google searches to no effect, I decided to cut my losses and spent 20 whole minutes building my own AMP stack with Wordpress from scratch.

 

Thanks for your positive reply! I really like my other Turnkey appliances, which is why I took the trouble to reg on and give you guys a heads-up that you have an issue with what I suspect is one of your more popular products.

 

ap

 

 

 

Jeremy Davis's picture

No problem here...

Out of interest I just downloaded and installed the v11.3 TKL WordPress OVF appliance. Within 5 mins of the download finishing it was running (on VirtualBox 4.1.8 under WinXP) and I was logged in as 'admin' using the password that I set on firstboot.

So I'm not sure what was going on for you with the password setting/usage for the WP login? I'm assuming that you were using the username 'admin'?!

Perhaps your VM image got a little corrupted on download? I have had very strange minor issues with other appliances in the past that I managed to troubleshoot to (what I assume must have been only a very minor) corruption (ie the ISO/VM image didn't pass the integrity check - but for the most part installed and worked fine).

Guest's picture

I didn't do a GPG

I didn't do a GPG check...

Since you guys are taking this seriously and I haven't given you much to work with, I'll re-download the appliance, check continuity, and reinstall the OVF on VBox 4.1.8 in another zone some time this weekend, then report back.

 

I think you guys got a good thing going here, and I have to respect the way you are responding.

ap

 

 

Guest's picture

Gain Access

I inherited a blog from my predecessor.  The linux turnkey server runs on a VMware guest version???

I do not know usernames or passwords.  Is there any way I can gain access to this box?  I need admin access to make changes to the layout etc.

 

Thanks,

Jeremy Davis's picture

Assuming that it is TKL v11.x

It should be pretty easy! You'll need to google how to reset your root user password using an Ubuntu Live CD (because I can't recall OTTOMH - although IIRC there is a post somewhere here that explains...)

Then you'll need to reset the WP password by running the firstboot script.

I would imagine that it would be

/usr/lib/inithooks/bin/wordpress.py 

or something similar, check with

ls /usr/lib/inithooks/bin/

If it's an older version then you'll need to manually edit the database. Do a google for 'reset my wordpress password" or similar... Sorry I can't give you specifics ATM...

Guest's picture

I realize this thread is a

I realize this thread is a couple months old but I am having a similar problem.  My set password does not work in Shell In A Box, Webmin, or PHPMyAdmin....but does work to log into the actual wordpress site.  I am completely baffled?

Guest's picture

I gave up. Then, a month or

I gave up. Then, a month or two later I stumbled across an issue with apostrophies in MySQL passwords. So I tried to import/run the Turnkey Wordpress OVF again, without apostrophies in the passwords, and I could log in. 

By then I had built the site on a different platform, but that's how it panned out for me.

Guest's picture

wordpress password

The password function to login in to word press simply does not work.  I have reloaded VM and turnkey several times.  The admin user name is either not correct or it is not loggin the password when sit up there is definately a bug somewhere.

Jeremy Davis's picture

Works here...

I just tested it and it works fine for me (username: admin password: as set with firstboot scripts). I tried a couple of different passwords to make sure it wasn't fluke (by rerunning the firstboot scripts)...

Perhaps you have a corrupted download? I'd check the download integrity (instructions in the docs).

Are you using a standard US keyboard? Also perhaps try using simple alpha-numeric characters only and then change it once you've logged in (maybe a special charaer is upsetting it?)

Guest's picture

Ok i downloaded agian both

Ok i downloaded agian both times using standard U.S. keyboard alpha-numeric characters both times this simply does not work.  There is a problem somewhere this simply does not work.  Logging in should be a relatively simple process.  I'm not sure what is going on I've wasted two evenings of my life that I will not get back.  I will now move on and build a stack myself.

Jeremy Davis's picture

Did you check the download integrity?

As I suggested above? Unless you confirm that you actually have a corrupt download, re-downloading is a waste of time really as perhaps the WP image on the particular mirror you are accessing are corrupt? But you have no way of knowing unless you test the image integrity (both the first timae and the second). I have had that happen with SourceForge before (although not with TKL images). Downloading from a different SF mirror solved the issue. 

I have just tested a couple of different formats now (v12.0 - OVZ and VMX) to test and they both work perfectly ok for me (and took all of about 15-20 mins to test both of them)...

Guest's picture

Ok I've had several people

Ok I've had several people look at this problem integrity checks out.  The reality is the generic admin username does not work with the password set during install.  The keyboard on several computers were all U.S. standard.  As I've googled this it seems to be reoccuring with alot of your products.  The iso file nets the same result.  Please do not reply that you have tested this and found no problems as I have tested this and found there is a problem.  Also researched after asking around it seems it is a rare occurance that SourceForge.  Several Linux gurus were not able to make this work.  

Jeremy Davis's picture

Well it obviously works in some scenarios...

Sorry to go against your wishes ("Please do not reply that you have tested this and found no problems as I have tested this and found there is a problem.") but the reality is that they work for me! I'm not saying that you are not having a problem (obviously it's not working for you) but it does work for me! There must be something in your setup and/or VM environment config (and that of others that have had the same issue) that is causing this problem.

Following your post I just freshly downloaded the ISO, VMDK and OVF builds and installed them all to VirtualBox v4.2.6 (running on Win7). I set a very simple root, MySQL root and WP admin passwords (I set them all to 'wordpress') and it all works for me... I can log in fine to SSH, local VM, Webmin, phpMyAdmin and the WP admin 'dashboard' using the appropriate username ('admin' for WP, 'root' for all others).

See the screenshots of me logged into the WordPress 'admin dashboard':

  

I'm not calling you a liar, but I am telling you emphatically that it works here...! I'm not sure why it doesn't work for you, but I'd sure as hell love to know why...! I didn't do anything special (just entered the root password twice, MySQL root twice and WP admin twice - I also didn't do the auto updates on the ISO for good measure, but they all worked!) and I certainly wouldn't call myself a Linux guru, but never-the-less they all worked for me...

Following the tests I did the other day I am out of options on what more I can test (unless I start downloading another VM enviroment, I tested the OVZ on ProxmoxVE (Debian 6 based) and VBox for all the others; I guess I could test the ISO in PVE too, but I'm pretty sure I know what I'd find...).

What VM platform are you using? Perhaps that's where the problem lays?

BTW they are not my products. I am just a community volunteer here...

Ric Moore's picture

Did the OP omit the turnkey-init ??

I bet that step was missed. Wordpress installed just fine for me. But you have to issue the turnkey-init command to properly set up the package. Some times I could not get the blooming terminal to open, so I login to my base install, then enter: vzctl enter <container number>

and then enter: turnkey-init

That correctly sets up the passwords for root, mysql and admin for WP.

Ric


Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)