steffen's picture

Hi All,

is there a way to enable webdav via webmin? I found an option to activate the modules but none

to configure the virtual hosts.

Or can you tell me what apache config file to edit to enable it for a specific host.

Thanks for you help.

Jeremy Davis's picture

But seeing as TKL v11.x is Ubuntu 10.04/Lucid under the hood then any instructions you find for that should directly relate to TKL. Sorry I can't help you any more than that...

steffen's picture

Hi Jeremy,

thanks a lot, following your hint I managed get it working with this very nice tutorial.


Jeremy Davis's picture

And thanks for posting back with the link to the tutorial that worked!

Snickasaurus's picture

And since TKL is now Debian based here is an updated link to a working config.

*Tested on Debian 7.4.0


[ ]

Jeremy Davis's picture

Thanks for posting a new tute! :)

steffen's picture

Be sure to activate the modules: (simply hit that into the shell)

a2enmod dav_fs

a2enmod dav

and add somthing like that to you virtual host config:


       Alias /webdav /anywhere

       <Location /webdav>
         DAV On
         Options None
         AuthType Basic
         AuthName webdav
         AuthUserFile /topasswd/passwdadmin.dav

         <LimitExcept GET OPTIONS>
         Require valid-user


Jeremy Davis's picture

Thanks for posting back, that's awesome!

Update: I decided to add this to the docs because I thought it is a very useful thing. I tweaked your example a little and added some extra detail. Please feel free to tweak it further if you think I got it wrong (the docs are a wiki so all logged in users can edit). Also I still need to double check it by testing it out to confirms that it works as it should.

If anyone has a chance and can double check, that'd be great! :)

steffen's picture

Yours is of course even nicer and it is the full story with permissions and password creation!
I tested it in one machine, when I use it again I will post it here!


Add new comment