i-zharskiy's picture

Trying to use TURИKEY Linux inside QEMU-KVM host (CentOS 6.4)  with these (little obsolete nowadays)
http://www.turnkeylinux.org/forum/general/20100426/recipe-install-turnkey-appliance-kvm-remotely-headless

Mounted LVM volumes:





[root@KVMHostCentos ~]# kpartx -av /home/kvm/turnkey-redmine-13.raw.img
add map loop0p1 (253:3): 0 876544 linear /dev/loop0 122880
add map loop0p2 (253:4): 0 38060032 linear /dev/loop0 1001472

[root@ KVMHostCentos ~]# vgchange -ay turnkey
2 logical volume(s) in volume group "turnkey" now active

[root@ KVMHostCentos ~]# mount /dev/turnkey/root /mnt/turnmineLVM



 

then i've got



 

[root@ KVMHostCentos  ~]# ssh root@IP.AD.DR.ESS -p 22
ssh: connect to host 192.168.222.98 port 22: Connection refused
[root@ KVMHostCentos ~]#




 

How to add console (TTY S01) to GRUB2 menu? Im afraid if it even possible using direct config editing without running config-scripts commands! Is it possibe to run Debian config scripts such as grub-mkconfig under CentOS chroot? How to achieve my purpose? Run with full path? OR what?



 

How to completely disable (turn off) netfilter (iptables ruled firewall)? Any ideas? Script? Config?




 

Forum: 
i-zharskiy's picture

VirtualBox Loading Initial ramdisk

Tried

turnkey-redmine-13.0-wheezy-amd64.vmdk

in VB under Win7 with no result


 

Jeremy Davis's picture

I too have had trouble running the 64 bit images under VirtualBox on Win7 (x64). This is despite having a CPU that definitely should support it and ensuring that all the appropriate options are enabled in BIOS! I think it may be a VirtualBox bug as Win7 x64 won't install to a VM either...

I have resorted to running the 32 bit versions of TKL if I want to run them on my laptop, otherwise I have a (headless) ProxmoxVE server which I use TKL OVZ templates on (or you can alternatively run under KVM if you prefer).

Waleed Hussein's picture

i had the same problem and managed to fix it by changing the OS system type in Virtualbox from "other" to "ubuntu (64bit)"

hebbop's picture

Setting the OS to Ubuntu 64 worked for me.

Thanks

Add new comment