Sam Mauer's picture

I'm using the revision control image installed on a physical machine, and it's been working fine for quite some time (uptime was at 168 days this morning).  I noticed that the last backup time was last Thursday.  I started by rebooting the server, and then I tried starting a backup manually and got this error: 

File "/usr/bin/tklbam-backup", line 513, in <module> 
File "/usr/bin/tklbam-backup", line 446, in main 
opt_resume, True, dump_path if dump_path else "/") 
File "/usr/lib/tklbam/", line 218, in __init__ 
saved_backup_conf = BackupConf.fromfile(extras_paths.backup_conf) 
File "/usr/lib/tklbam/", line 76, in fromfile 
d = simplejson.load(file(path)) 
File "/usr/lib/pymodules/python2.6/simplejson/", line 328, in load 
use_decimal=use_decimal, **kw) 
File "/usr/lib/pymodules/python2.6/simplejson/", line 384, in loads 
return _default_decoder.decode(s) 
File "/usr/lib/pymodules/python2.6/simplejson/", line 402, in decode 
obj, end = self.raw_decode(s, idx=_w(s, 0).end()) 
File "/usr/lib/pymodules/python2.6/simplejson/", line 420, in raw_decode 
raise JSONDecodeError("No JSON object could be decoded", s, idx) 
simplejson.decoder.JSONDecodeError: No JSON object could be decoded: line 1 column 0 (char 0) 

After searching the forums, I have tried:

  apt-get update && apt-get install tklbam => already on latest version


  rm /var/lib/tklbam/backup-resume

  try backup again => same error


  rm -rf /var/lib/tklbam


  try backup again => same error.


Server is running with 3 GB of memory and this is all it's doing; any suggestions?


Thanks in advance

Jeremy Davis's picture

I just realised that this post never got replied to. Apologies that it got missed. For the record it looks like someone else had the same issue and it was answered over here. They reported that using the '--disable-resume' switch to the tklbam-backup command resolved the problem.

Add new comment