Hendrick's picture

I am running Orange HRM in VirtualBox. In the past I have no problem with tklbam, backup is o.k. But now when I want to use tklbam backup, it does not work and I get the following message:

What can I do to solve this problem? I would appreciate it if anyone can help. Thanks!

Hendrick's picture

this is the message I get:

> tklbam-backup
Traceback (most recent call last):
File "/usr/bin/tklbam-backup", line 366, in <module>
File "/usr/bin/tklbam-backup", line 294, in main
if not conf.simulate and not opt_disable_resume and registry.backup_resume_conf == conf:
File "/usr/lib/tklbam/registry.py", line 167, in backup_resume_conf
return BackupSessionConf(simplejson.loads(s))
File "/usr/lib/pymodules/python2.6/simplejson/__init__.py", line 384, in loads
return _default_decoder.decode(s)
File "/usr/lib/pymodules/python2.6/simplejson/decoder.py", line 402, in decode
obj, end = self.raw_decode(s, idx=_w(s, 0).end())
File "/usr/lib/pymodules/python2.6/simplejson/decoder.py", line 420, in raw_decode
raise JSONDecodeError("No JSON object could be decoded", s, idx)
simplejson.decoder.JSONDecodeError: No JSON object could be decoded: line 1 column 0 (char 0)

Liraz Siri's picture

Try either:

  1. adding the --disable-resume option to the tklbam-backup command.

  2. Removing /TKLBAM:

    rm -rf /TKLBAM

Both should work. I've seen this happen before and I think I know what is going on. In any case I will add some robustness to the code in the next update to prevent this from happening. I opened a bug report:


Hendrick's picture

Thanks for your assistance. I appreciate it.

I tried the second option first, it did not work. still got the same message.

Then I tried the first option. It works.


Add new comment