Olivia's picture

Hi TurnKey Society,

I've had a lot of positive experiences with my new Samba Debian PDC Turnkey server, and all works well. Expet from one thing, and that is roaming profiles.

When I log in as a domain account on a host machine, I can do that, but it would say that it is running as a temporary profile and not a roaming profile. I am not interested in running with roaming profiles, but where can I avoid this?

If a domain user saves a file after logging in, that file is only temporary and will not be there when the user logs off again. They do have access to the right storage shares, but the local vs roaming profiles are not working.

Is there anywhere I can disable this?

Olivia's picture

The error description is:

"Windows cannot find the local profile and its logging you on with a temprary profile. Changes you make to this profile will be lost when you log off."

Olivia's picture

Problem was solved.

Jeremy Davis's picture

Great that you got your issue solved and sorry that no one got here to help you.

If you have a chance could you please post back letting us know how you fixed it which might help others in the future? Thanks.

Olivia's picture

Sure thing, all I did was log in as the local administrator on the clients computer.

after that, I followed these steps


  1. Open Group Policy Management
  2. Navigate to: Computer Configuration\Administrative Templates\System\User Profiles.
  3. Enable “Only allow local user profiles” and “Prevent Roaming Profile Changes from propagating to the server” to disable roaming profiles on this machine or GPO.

And this resolved my issue. Now all of the domain users logging in are logged in as local users.

Jeremy Davis's picture

Great thanks :)

Add new comment