Jason van Wyngaard's picture

Hi

I've got a static IP and setup dedicated URL for my LAMP instance. Using the Hub console the only name it uses to connect to webmin is the dyndns that was assigned to it.

Accessing my site is fine, I just can't connect to webmin. I've tried using the dyndns name, my dns name, the IP and the site will hang for a very long time till I stop it from loading and sometimes the dashboard will appear. From there I try to access Backups and only once have I managed to do a backup (about 3 weeks ago), since then I just can't get in.

The fact that it eventually connects at some level tells me that something is blocking it. I connect over https and get a warning that the root certificate is not trusted and must be installed in the Trusted Root Certification Authorities Store, could this be the reason for the poor speed?

URL I access: https://aurikbmc.tklapp.com:12321

Your help is appreciated.

Kind regards

Jason

Forum: 
Jason van Wyngaard's picture

The fundamentals of maintaining a system is being able to access it and back it up. Since I'm not a linux guru I rely on Webmin to get this done. Right now I can't access Webmin. 

I'm requesting help. Please.

 

Kind regards

Jason

Jeremy Davis's picture

Firstly the certificate warning would not be the issue. To avoid the security certificate warning you will need to purchase a certificate from a verified Certificate Authority (CA). Self signed certificates will always throw a warning such as this (IIRC there is a workaround to basically create your own internal CA but it still won't work for other users).

Having said that, I have in the past had issues loading SSL (i.e. HTTPS) pages if the certificates have been rejected (within the browser). First thing I'd try is a different web browser (e.g. Chrome, Firefox, etc). And/or you could try clearing all browser data. Bottom line is that I'm 99% sure that it's something on your end.

FWIW I tried connecting to your server (via the link in your OP) and it works straight up for me no worries...

Daniel Fernando Ribeiro Cesar's picture

I am loving the turnkey, i am install him in my BIG website www.unidosnafe.com.br.

My website has more of 16000 articles...

Is fast, good, i loving, but....

The webmin is disappeared from yesterday!!!

Test... https://www.unidosnafe.com.br:10321

Ããããa i am only, copy my files, install the databases sql, only this.

What can be?

Regards,

Daniel Cesar

 

Daniel Fernando Ribeiro Cesar's picture

Hello, Jeremy

I cant acess: https://www.unidosnafe.com.br:12321

But I cant acess: https://www.unidosnafe.com.br:12320 work

I cant acess: https://www.unidosnafe.com.br:12322 work

Only 12321 stop work

What can i do?

The website is ok! No problem, only 12321 stop!!!

Please help,

Regards

Daniel Cesar

 

Jeremy Davis's picture

I'm not sure why but I never saw this thread/post. Sorry that my response is so ridiculously slow/late. :(

I hope you got your issues sorted.

FWIW for future reference, it's usually best to start a new thread (rather than post on someone else's). If you want to try to reach the previous users or an old thread, post a link to your new thread... The exception to that is if the existing thread is quite new (i.e. within the last month or so) and your issue appears to be EXACTLY the same.

ddlab's picture

Even if this may not be the right answer, but this may be a helpful hint for those who experienced trouble with webmin. May be you tried to upgrade webmin to newer version? I did, using webmin-current.deb and I was told, that some dependecies could not been resolved (or something like that). My first approach was to

apt-get -f install

and immediatly the install script did continue and - yupp - everything fine. Now running 1.730 with a lot more options. Hope this may help to somebody.

Shane Mundee's picture

I'm having the same problem.  Wordpress main website works just fine -- just unable to open the instance's webmin hyperlink.  I've already tried multiple web browsers, rebooted; revered hostname back to default 'wordpress'.  Pretty much stuck.  Anyone have an idea?  Note: This same problem is happening across all my tkl-wordpress VM's - 15 of them!

--Shane Mundee, Dallas Technology Solutions

 

Jeremy Davis's picture

What version of TurnKey are you using? Are these new/fresh installs? Or migrated from previous installs (i.e. via TKLBAM)? Where are they being hosted (locally, AWS; some other VPS) and how is the networking configured (e.g. behind NAT router/firewall, etc)?

Add new comment