fabvlvs's picture

Following instructions here:


Building core worked perfectly, and produced the file build/product.iso

I cloned project pier into the products folder and ran make on it just the same as I did with core, but build/product.iso was not created.  Only a build folder with some files in it, but not the product.iso folder.

Is it supposed to be the same proces to make any source into an iso?  Am I missing a step?

Liraz Siri's picture

You are not missing a step. It's exactly the same process for all apps. Perhaps something broke with the Pier build process? The build process is very verbose. Can you see where it stopped and post it here?

Liraz Siri's picture

Sorry for the inconvenience. I tested that comments work. I'm not sure what happened to the one you posted. Maybe the spam filter ate it. Anyhow, I whitelisted your account to bypass the spam filter.
fabvlvs's picture



I might have smething else going wrong, however because I can't make anything except for core.


here's me trying to make two others:

Rails appliance:



nascent foodsoft appliance




Jeremy Davis's picture

And whilst I spotted a few errors/warnings I didn't see anything that I thought would be fatal. However I have had issues at times if a build fails, then sometimes some cruft is left behind that will make subsequent builds also fail. I'd suggest that you reboot your TKLDev server and then run make clean and try again.

Also I don't think it is the case on this occasion but there have been occasions where something changed upstream and it makes a TKLDev build fail. I don't think that is the case in this instance, but figured I'd mention it as it has happened...

Martijn Verwijmeren's picture

All build templates somehow inherit the command:

/usr/share/fab/make-release-deb.py /turnkey/fab/products/core/changelog build/root.patched

This makes it quite obvious why only core can be built, as it always tries to do something with a file in "products/core" even when you are building another appliance. So either this has to point to "products/WhateverIamBuilding" in which case this is a bug. Or it has to be documented clearly that you always have tot have core cloned too.


P.S. I tried posting more of the error log, but it immediately triggered the spam filter.

Liraz Siri's picture

Hi Martin, sorry about the spam filter issue. There was a bug with a new countermeasure I implemented. All better now.

Liraz Siri's picture

I think we never came across that issue before since we always use Core as a test case before attempting any other build. It should be trivial not to depend on that. I just have to test the fix.

In the meantime, the workaround is to install Core to /turnkey/fab/products. Like this:

cd /turnkey/fab
mkdir -p products
cd products
git-clone https://github.com/turnkeylinux-apps/core

Add new comment