Jayaram's picture

Hi,

 

I'd like to set up the Turnkey OpenVPN so that it works over TCP and on a different port than what's configured by default.

 

Changing the server.conf and restarting openvpn service doesn't seem to help.  Changing the startup shell script (that I found by grepping for 1194) for openvpn also didn't seem to help.  I also couldn't find any easy way to change it anywhere else.

 

Appreciate if someone could help me with this please.

 

JV

Forum: 
Jeremy Davis's picture

I'm certainly no OpenVPN expert (TBH I've never used it...) but AFAIK you would adjust the conf file, e.g.:

nano /etc/openvpn/server.conf

And then restart

service openvpn restart

But it sounds like you tried that and it didn't work... Did you reopen the conf file to make sure that your changes had been saved? Also depending on where you're running it, make sure that you have the rest of the network (e.g. firewall, NAT router, etc) preconfigured to work with the new protocol...

I just had a quick dig and perhaps the Debian OpenVPN wiki page might be of some help/guidance? (TKL is Debian based and AFAIK OpenVPN is installed from Debian package management). Sorry I don't have the answer, but if you find it, please post back...

Jayaram Veeraraghavan's picture

I had tried modified server.conf and restarting openvpn (and the server itself) and the changes didn't take effect.  Yes - the file itself was modified correctly (I could vi and still see the changes I had made) but it didnt' show up in OpenVPN itself.

 

I had also seen that the startup script (the name escapes me now) replicates the entire server.conf configuration and I had modified that too - still to no avail.

 

Will go through the Debian OpenVPN documentation and see if that helps.

persianhero's picture

Hi,

have you managed to sort it out?

Jayaram Veeraraghavan's picture

No, I gave up and started using the OpenVPN that comes built-in with my Netgear Nighthawk router.  Setting that up was a breeze (with UDP or TCP) and it's working well enough for my purposes.

Sascha's picture

I was not getting why it doesnt work... I did not receive any packet from the server on 2 different clients and I checked if the service is actually running and it looks to me like it just fails to start up.

openvpn/logs# service openvpn restart

[ ok ] Stopping virtual private network daemon:.

[FAIL] Starting virtual private network daemon: server failed!

and

openvpn/logs# /etc/init.d/openvpn start

[FAIL] Starting virtual private network daemon: server failed!

I did not do any manual changes to any configs, just generated a user profile. I'll try to figure out how to fix that, but so far did not find out how to increase the verbosity of above output.

Jeremy Davis's picture

If so, I'll have to have a look into it and see what is going on. In the meantime I have opened an issue on our Tracker.
Anton Pyrogovskyi's picture

You are not running the latest version of TurnKey Linux. Please use the latest version from https://www.turnkeylinux.org/openvpn and let us know if the problem persists.
Jeremy Davis's picture

Thanks very much for looking into this.

Add new comment