Dear admin,

I'm a CAnvas newcomer . I have just installed turnkey canvas 14 . It seems all working properly but email..

So when we invite users , seems no email received by user

Another info is I'm using postfix as mta to another smtp server . Email is working when we send email through command line .. The outgoing_mail.yml is already set to the smtp server ip address .

Is there any steps we missing ?

Thanks

Teddy

Forum: 
Tags: 
Jeremy Davis's picture

Although that obviously not the case for you...

I just did a quick google and the Instructure wikirecommends that you check the last error that Canvas had (if any) after some scheduled job (such as email) by running:

psql canvas_queue_production -c "select last_error from delayed_jobs order by updated_at desc limit 1;"

Does that give you any hints?

I have run this command but return nothing .. Please advice ..thanks

psql canvas_queue_production -c "select last_error from delayed_jobs order by updated_at desc limit 1;"
Jeremy Davis's picture

Thanks very much for reporting Teddy. We can confirm that this is a bug in the Canvas appliance. I have lodged it as a bug on our issue tracker.

We are currently working on a fix and will provide a workaround ASAP.

Jeremy Davis's picture

I have discovered that the issue is because the Canvas "delayed job" backend is not running; hence why there also are no errors. I have worked out how to fix it but need to do a little more testing to refine the exact minimal fix. I will post back ASAP.
Jeremy Davis's picture

Here's the workaround.

You'll need to login as root and copy/paste the following:

adduser --disabled-password --no-create-home --gecos "Canvas user" canvasuser
adduser canvasuser www-data
echo "PassengerDefaultUser canvasuser" >> /etc/apache2/sites-available/canvas.conf

WEBROOT=/var/www/canvas
USER=canvasuser:www-data
chown $USER $WEBROOT/config/*.yml
chown $USER $WEBROOT/config/environment.rb
chown -R $USER $WEBROOT/log
chown -R $USER $WEBROOT/tmp
chown -R $USER $WEBROOT/public

service apache2 restart
service canvas_init start
Then it should all work as it's meant to...

Hi Jeremy,

Thank you for quick responses .. It seems working properly now .. Two users said they received email ..

Thanks once again

Teddy

 

 

Jeremy Davis's picture

We'll update the build code so v14.1 won't have this issue. Thanks again for reporting. And for being patient while we worked out a fix! :)
Ced's picture

I can see that these config options work on apache2... but I'm currently using Nginx with the same issues. What workarounds do you offer?

Jeremy Davis's picture

I suggest that you contact Canvas community support. I think Instructure (the mob that make Canvas) have a community forum.

Add new comment