Hubertus Becker's picture

Hey, friends,

first of all: I'm a newbie to TKL.

I started to work with it a few weeks ago. I installed the LAMP-stack (14.0) to a standard-pc for testing it. Everything worked fine.

Now I tried to install the LAMP-stack to new server hardware with UEFI and two identic hard drives for software- RAID1. The drives are already partitioned with GPARTED (on each drive identical partitions, i.e. each one EFI system partion, one ext4 partion and a SWAP-Partiion).

Unlike Debian standard the TKL partitioner of the installation routine doesn't offer the option to use a partion as physical volume for RAID (at least I didn't find it), so there is no chance to configure raid during installation. Would you recommend to install the appliance to a single hard drive first and configure RAID in a second step?? I've read in older threads that it should be possible, but is there meanwhile a more simple solution integrated in the appliance, that I don't know?

---

During testing on the new hardware I started the Live CD demo mode. The installation ended up with an error message of the Configuration Console "Network is not yet configured". Trying to configure it manually:

Error obtaining IP address

udhcpc (v1.22.1) started
Sending discover (3x)
/etc/udhcpc/default.script: Lease failed:
No lease, failing
Failed to bring up eth0

dmesg output:


dmesg

Seems to me that the lan connection cannot be established due to the missing driver for the onboard realtec ethernet adapter.

No driver - no connection. No connection - no automatic driver download ... grrrrrrrr

Meanwhile I found the Realtec firmware package on https://packages.debian.org/de/jessie/firmware-realtek

According to the installation instruction I untarred  the GZ file to a usb stick and tried to load the firmware with the "debian-installer" bash command but I got the error: "command not found" :-/

I know, something installed in live cd demo mode disappears on restart. I just wanted to test, if the missing driver is the reason for the connection error in fact.

I'm really at my wits' end.

Any help highly appreciated

Forum: 
Jeremy Davis's picture

Personally I've never run TurnKey on bare metal. I prefer to run it as a VM. Actually I use Proxmox as my host and then run multiple TurnKey containers. But I digress...

Regardless you are right; the installer doesn't support RAID install. It should be quite possible to set it up after install but I can't offer any suggestions on that as I have no experience.

With regards to your driver issue. You don't need to unpack it, just copy it onto the USB, mount the USB and install it in your TurnKey appliance. This should do the trick:

dpkg -i firmware-realtek_*.deb
Hubertus Becker's picture

Hi Jeremy,

thank you very much for your prompt reply.

Due to your hint I've now found the right download location with the .deb package :-D

OK! Regarding RAID,  it shouldn't be difficult to find a generic tutorial to succeed with the installation.

Best regards,

    Hubertus

---

SOLVED

Jeremy Davis's picture

If you keep in mind that TurnKey is Debian under the hood (v14.0 = Jessie; which you seem to understand already, but just in case...) then there should be plenty of info online.

If you find something that is helpful (and works) then please post back with links, hints, etc so others may follow in your footsteps! :)

Hubertus's picture

I'll do so ;-)

Jeremy Davis's picture

Awesome :)
Hubertus Becker's picture

It seems to be more difficult than I thought to install TKL to a UEFI RAID system ;-)

The Debian partitioner doesn't neither support RAID nor does it offer the option to use a partition as EFI boot partition.

In a Debian forum https://www.reddit.com/r/debian/comments/2brmp2/installing_debian_jessie_in_uefi_mode/ I found a hint that

The install medium must be booted as UEFI when installing an UEFI O/S. This is so the installer can be aware of and update the existing EFI partitions.

So I decided to use a USB stick for installation. As UNETBOOTIN doesn't support UEFI I tried RUFUS (Win prog, shame on me ;-)), but RUFUS aborts installation after selecting GPT for UEFI and the turnkey-lamp-14.0-jessie-amd64.iso with error message

When using UEFI Target Type, only EFI bootable ISO images are supported. Please select an EFI bootable ISO or set Target Type to BIOS

what says to me that either the iso itself isn't EFI bootable in fact or RUFUS isn't able to handle the iso correctly, respectively to produce the right partions (EFI system partion with bootx64.efi, etc., and a further partition for the rest).

Now I've already read umpteen tutorials and forum threads how to "manually" create an EFI GRUB2 BOOT USB drive but none of them has lead to success 'til now.

I'll keep you informed ...

Hubertus Becker's picture

CORRECTION:

UNetBootIn DOES support UEFI, but the ISO must contain the appropriate structure, what the turnkey-lamp-14.0-jessie-amd64.iso unfortunately doesn't do :-(

No RAID support and no UEFI compatible installation-ISO ... that's a pity and I'm running out of time meanwhile. The Ubuntu Server edition has got all that stuff onboard but I'm really loving the TKL LAMP stack, because handling (with Webmin, etc) and pre-configuration is perfect.

Any idea how I can proceed?

Jeremy Davis's picture

My laptop has UEFI and it installed (and runs) Debian Wheezy fine. I don't recall doing anything special (just next, next, next) when I installed it. But perhaps it was in "legacy BIOS mode" off the shelf already? Also it was a while ago so things have probably changed.

Like I said I don't install TurnKey on bare metal. I use the ProxmoxVE Hypervisor and install Turnkey as containers (you can download them directly through the web interface). I installed that to my new server (which also has UEFI) and it all just worked OOTB. But our installer is more modified (to support running live) that the one Proxmox uses?

As for UNetbootin; I haven't used it for years but I know that many people have issues using it to install more recent versions of Debian, e.g. here. I just use the commandline tool 'dd' (e.g. 'dd if=<iso-file> of=/dev/<usb-drive>'); but I'm on Linux (and Win doesn't have it) so unless you are running Linux (or OSX) somewhere handy, that won't help you... You could try Rufus, I've heard good things about it, but never used it myself. Although perhaps it is simply an issue with our installer (on your hardware)?

I just noticed someone saying that similar issues (as UNetbootin) also occur with Rufus. The Debian docs recommend Win32 Disk Imager. (There is also mention in the docs there on not using UNetbootin...)

Hubertus Becker's picture

... is a closed book for me, I've never mucked about it before. As mentioned above I'm running out of time. But, nevertheless, I'll take a look at Proxmox. Perhaps it's easier than I think :-)

I've disposed of Windows many months ago ;-) I'm using Linux Mint on my computers "stand alone" not in dual boot environment. I only used Windows to test Rufus, but, as I've said, Rufus is not much different from UNetBootIn, both need an image with the typical UEFI folder structure  (with /EFI/BOOT/, etc).

OK, using 'dd' could be a good idea. I'll test it.

Jeremy Davis's picture

If you don't pay for a subscription there is a nag screen everytime you log in, but I often keep a browser tab open so I log in very rarely! :)

And apologies on assuming that you were running Windows. Had I known I would have suggested dd straight up.

Also I did a little more reading and it seems that you may have been right all along and our installer may just not support UEFI.

If you can confirm that (assuming you try writing the ISO with dd) then please let me know and I'll lodge it as a bug.

Add new comment