JacobsCHAOS's picture

My old site was using zen-cart 1.5.4. I had upgraded it several times on my old host to get it there. When I tried to upgrade on TurnKeyLinux, so I can import my old database, I cannot get the upgrade to work. I copied the new files in place (I tried with 1.5.3 and 1.5.4). I've check the read write permissions on the folders and files, but I am still getting access permissions when trying to access zc_install, and when I remove it I get access permission errors when trying to log in. I am not used to using debian, so maybe there is just something different/additional I need to do.

JacobsCHAOS's picture

I verified apache is running as www-data. I changed the user and group to match apache and chmod'd everything to 777. So, it is definitely not a regular file permissions issue. Any thoughts on what it could be?


I created a new directory on the server /var/www/test and copied a clean copy of zen-cart 1.5.4 into it, and I still can not execute the installation scripts in zc_isntall. I can see the contents of the demo folder adn the I can create an info.php file in teh zc_isntall folder, but I can not run the install scripts. I'm still looking for ideas on what could be blocking it.

Jeremy Davis's picture

It probably shouldn't matter seeing as you have set 777 permissions (although FWIW that's a really bad idea...). Here's what I'd do:
chown -R www-data:www-data /var/www/zencart
chmod -R 744 /var/www/zencart
If it still doesn't work then perhaps the issue is actually permission to write to the DB (rather than the filesystem)? Perhaps copy paste the error message you are getting.

Add new comment