i give up


Jeremy Davis's picture

So to clarify: You are currently serving your website from Windows running on bare metal (i.e. a physical PC - not a VM). You have installed TurnKey LAMP from ISO (via USB) on the same hardware or hardware within the same LAN?

It looks like your domain points to a static external IP.

Regardless, it sounds like TurnKey is working fine, but your network config needs adjustment (although probably easier to adjust TurnKey than your network). My guess is that your Windows server has a static LAN IP set. And your router/firewall is configured to forward traffic to that IP. When you start TurnKey is it getting a LAN IP via DHCP. But because it doesn't match the IP that the network is configured to server your website - it's not working...

Assuming that I understand your setup right and my guess of the issue is also right; what you'll need to do is find out what that Win machine's IP is. Then set the static IP in TurnKey to use the same IP as the Windows server.

You should be able to find your Windows IP address from the Windows commandline with "ipconfig". From what you've said already, I'd guess it should be an IP that looks something like 192.168.1.x where 'x' is a number between 1 & 254. Write that down, then in TurnKey use the Advanced option to set the static IP to be the same as that.

Note: if the Win & TurnKey servers are on separate machines (and the Win server is still running) then you'll need to change it's IP (or shut it down, or disconnect it from the network, etc). 2 machines on the same LAN with the same IP will cause problems. It's a bit like if another house had the same address as you - the postman would sometimes deliver your mail to the wrong house!

If you only intend to serve one website then that's all you need to do, you don't need to configure a virtual host. You may want to later on, but at least to start with it just over complicates things and will likely lead to more issues.

As for installing the PHP GD library, that's really easy.

From the commandline on your TurnKey server, run this:

apt-get update && apt-get install php5-gd




Jeremy Davis's picture

It sounds like you had a frustrating time.

It's a pity that I wasn't available over the weekend to help you out. Or even if you could have kept the Win server serving your site while waiting for responses to me as I'm sure we could have worked it out.

Out of interest it looks like your site is down now anyway!? Is that a coincidence?

As a quick test, I just launched a TKL LAMP server on my LAN to check it works as it should. I didn't do anything other than the initial setup (passwords, install updates etc) and then set a static IP.

I confirmed that it worked via IP on my LAN. I then configured my router to forward port 80 and 443 to the server it all just worked... So not sure what was happening on your end. Either there was a networking issue, or perhaps in your initial tweaking something got broken?

FWIW you didn't need to delete all your posts. Good luck in your future endeavours.

then i  followed   youtube video about  bind system.

but  no luck, my conclusion was   something  in turnkey  conflicts  with  me  getting  online.
so i removed   some virtual hosts that  i guess  pointed  to  your  server  but  that diddent  help.

instead my plan is  to  install a clean debian (debian-8.5.0-i386-netinst.iso) setting  al up from  scratch and try  everything   again, to see if  im right.

i have my site  up  when  im  at my windows system and  when i test  linux i shut down  win syetm.  so  sometimes there is   soemthing  sometimes there is  not, ;)


Jeremy Davis's picture

If I understand you network properly, With a clean install of TurnKey, with no modifications it should all just work (after you set the static IP same as Win server).

No adjustment to Apache config or hosts files is needed (so long as you are only serving one domain). You may wish to tune stuff later, but initially you just want to get it working. Also there is no need to install or configure bind unless you want to run a local DNS server.

Your domain already points to your external static IP so that should be fine. And from what I understand of what you have written, your router already forwards port 80 (and perhaps 443 too) to your Win server's static IP (proven by the fact that your Windows webserver was working).

So all you should need to do is to set your TurnKey server's static IP to the same IP as your Windows server. Then it should just work (so long as there is not a IP conflict i.e. if your Win server is not running).

The fact that you can see the TurnKey server via IP on your LAN demonstrates that it was working ok. All you need to do is ensure that the traffic coming from outside your network is being correctly routed to the TurnKey server. So long as you are forwarding the traffic properly (which shouldn't need adjustment so long as you use the same static IP for TurnKey as your Win server was using) all should be well.

Actually you can test whether it's some domain issue or a networking issue, by browsing to your external IP ( instead of your domain name. If you can

Personally, before you try Debian, I suggest that you do a clean install of TurnKey to eliminate the possibility that something you have adjusted is what is causing your issues.

Regardless, if you go with vanilla Debian good luck with it. Although I suspect that you will encounter exactly the same issues though. To me your problem appears to be with your network config, not with TurnKey.

Add new comment