roller24's picture

Hey Jeremy, I had owncloud up and running ok, and for unfortunately destroyed it, to work with a fresh install.

I did notice there are some cert files with owncloud still floating around on the root server lxc-containers that I use as my base operating system. (I don't think that's the issue, but just adding all the info I can.)

I immediately received the unknown domain error, and then on refresh received this error .

[Fri Jan 11 13:59:05.647560 2019] [:error] [pid 385] [client] PHP Fatal error:  Uncaught Doctrine\\DBAL\\DBALException: Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [2002] No such file or directory in /usr/share/owncloud/lib/private/DB/Connection.php:62\nStack trace:\n#0 /usr/share/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): OC\\DB\\Connection->connect()\n#1 /usr/share/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\\DBAL\\Connection->getDatabasePlatformVersion()\n#2 /usr/share/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(328): Doctrine\\DBAL\\Connection->detectDatabasePlatform()\n#3 /usr/share/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(623): Doctrine\\DBAL\\Connection->getDatabasePlatform()\n#4 /usr/share/owncloud/lib/private/DB/Connection.php(145): Doctrine\\DBAL\\Connection->setTransactionIsolation(2)\n#5 /usr/share/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/DriverManager.php(172): OC\\DB\\Connection->__construct(Array, Object(Doctrine\\DBAL\\D in /usr/share/owncloud/lib/private/DB/Connection.php on line 62, referer:

I checked service --status-all and found mysql was [-] so I attempted to restart with service not found errors. 

I tried all the db servers mysql, mysqld, mariadb, sqlite with all resulting in the same error.

I then went to github to see the latest changelog, and found that removal of the mariadb during security update as an issue. 

How should I resolve? just re-install mariadb? I will try that, but leave this here, and only return if successful.


roller24's picture

I tried the reconfig script as well and received the same error there right after setting the domain.


roller24's picture

reinstalling mariadb fixed this issue 

Jeremy Davis's picture

I'm really glad to hear that you fixed your immediate issue, but unless this/these are old containers that you've intentionally launched (which I'm assuming you didn't) then this shouldn't have occurred! The most recent images should all have that bug fixed.

Could you please share a bit more info? I'm assuming from your post (and your previous statement that you're new to TurnKey) that this was a (very?!) recent download/install of our ownCloud container?! If so, could you please share the version of the (broken; but now fixed) container. The easiest way to do that is from within the container itself:


I suspect that will confirm my suspicion that this is an old v15.0 build.

Also could you please confirm whether you were/are explicitly starting a specific version when you start the container. I'm assuming that you used the LXC tools to launch this container, which via our wrapper, should by default auto download the latest version. Unless of course you explicitly specify a version. If you have it handy (bash history?), sharing the exact command you used may assist too?!

Unless you explicitly downloaded/created a v15.0 ownCloud container, it sounds likely that there is a bug or issue somewhere. It may be a bug in the way the LXC appliance is resolving the version to download, although a caching timeout bug, internet access issue, or maybe even an out of sync mirror (where both the Proxmox data file and the images are hosted) seems more likely on face value.

I say that, because as per the ownCloud appliance page and the ownCloud appliance changelog, the latest v15.1 release should have solved that issue. Also according to the Proxmox aplinfo.dat (text) file (where the appliance gets info about the latest version) the latest ownCloud appliance is v15.1.

roller24's picture

I downloaded the package using the TurnkeyLXC command lxc-create this morning. 

I made it a point to remove the previous copy, from /var/cache/lxc/turnkey/ to ensure I received a new gz file, as i thought the other had become corrupted. 

lxc-create -n oc1 -f /etc/lxc/bridge.conf -t turnkey -- owncloud -i /root/inithooks.conf  -v 15.0-stretch

I see now that the -version tag... I must have been confused. I was under the impression that this was the version number of my LXC base APP, which it is. and I thought this was the version that the tag refferred to because using the same -v tag for all my APP installs has loaded APPs that were varied in version numbers. 

For example, I use the same lxc create command each install and only changed the names of the app and template name. Yet here is my cache listing.  


It seems to grab the most recent version of each.


Jeremy Davis's picture

So as a general rule, unless you specifically want/need a particular version, you're best off to skip stating the version.

roller24's picture

I joined this forum the same day I began using turnkey which was 10 days ago, so I could not have obtained a previous version without intent. So... Am I confused about the -v tag? or does the LXC container app use another repository? 

Jeremy Davis's picture

As I noted earlier, the LXC host appliance pulls the list of latest appliances from the (Proxmox) aplinfo.dat file. As you can see on the mirror, that was last updated 2018-12-02 so just over a month ago.

So as you note, unless you used the -v/--version switch, you should be pulling the current/latest versions. FWIW, you can find all the available LXC builds on the mirror here.

There is a chance that there is a mirror which is out of sync (i.e. giving you an old aplinfo.dat file). I haven't had any other reports recently, so I think that is unlikely, but it has happened before.

There is also a chance that there is a bug within the code that does the download and parsing of the aplinfo.dat file. Again there haven't been any other reports of issues with it, but that certainly doesn't mean it's not possible. I'd like to hope not, and I definitely tested it quite extensively myself (I didn't write the code that does that, but I did test it) but I can't rule it out...

roller24's picture

I did read through the lxc-create turnkey template and have a better understanding of how it works,especially the -v tag. THanks for the help. 

lxcs are uncharted territory for me. I ve always set up single use servers mostly apaches with ispconfig, using howtoforge tutorials.


Add new comment