Wade's picture

I've tried installing multiple versions of Turnkey Linux, but right now I'm using the LAMP ISO install in VMware Workstation 15.

When I boot Turnkey Linux using a NAT network in the VM settings, it runs without complaint. However, when I set the network type to "Bridged," the VM can no longer connect to the network at all.

I get the same errors as the people in this post:


I am at my wit's end. I need to set this up in VMware Workstation for a school assignment.

It's extremely unfortunate that Michael (the OP of the post linked above) only came back to rant about how lazy you all are rather than tell us his solution...

Jeremy Davis's picture

It looks like your TUrnKey server can't get a DHCP lease from your network. In a non-commercial network, often it's your router that provides DHCP leases.

So my guess is that the issue lays outside TurnKey. The fact that you have tried multiple TUrnKey installs with the same result, all but confirms that's the issue IMO. My suspicion is further confirmed (at least in my mind) by the fact that NAT appears to work fine (it would use VMware's internal DHCP server on the NAT subnet).

So that leaves you with 2 options:

  • Try to diagnose the issue on your network. First step would be to check your DHCP server (if you don't know where that is, it's most likely within your router). If all else fails, try rebooting your DHCP server (probably your router).
  • Set a static IP for TurnKey.

If you try setting a static IP, ideally it should be outside the range of IPs managed by your DHCP server, but still on the same subnet. If it's your router providing DHCP and you've never fiddled with it, it may well be managing the entire subnet. In that case your best bet is to just try to pick an IP address as far away from the existing allocated IPs (but there is still a risk that there may be an IP clash at some point in the future - although if this is only a short term project, then that's probably of limited concern).

If you don't know what I'm talking about when I say "subnet", then check the current IP address of your PC. It will likely be something like 192.168.x.x (where each x is a number between 1 and 254), although there are a few other network address ranges that can be used (either 10.x.x.x or 172.x.x.x). If your local IP address is outside these ranges, then that would suggest that you have a direct internet connection and you will need to configure NAT to forward the ports you need to be public. An alternative would be to give your VM 2 vNICs and configure one as NAT (so it has outgoing internet access) and the other "Host only" (so that you can connect to the server from your web browser etc). I'm not super familiar with VMware products, and no nothing of your network, so I can't really provide much more guidance on that.

If you IP is within one of the above ranges, then try setting a static IP address for your server. Use the IP that your PC has, but change the last number. E.g. if your PC has, try setting your TurnKey server to be (for example). If you get any strange results trying to access your server, then try an alternate IP (perhaps there is already something else with that IP? I.e an IP clash).

Good luck with it.

Add new comment