Sytko's picture


Gitea 17.2 - admin not login

Username or password is incorrect.

I create a new user, he produces authorization.
Why is the "admin" authorization not working?

Jeremy Davis's picture

I'm not sure why that is?

One guess is that perhaps Gitea didn't like the password you set?

Or are you perhaps using a keyboard that isn't US-International compatible? In that case, some characters may have been misinterpreted when you set the password initially, but then interpreted correctly in your web browser?

You can try again by re-running the first boot script, like this:


PS apologies that my response was so slow...

duck's picture

Sanitize the password script, it sucks, or define what does and doesn't work and that you should change the password after first login.

Wouldn't take my SYMBOLSupperlowercasenumbersSYMBOLS password. So I used 12345678Ab!. Once I logged in I could change it to SYMBOLSupperlowercasenumbersSYMBOLS and it worked fine.

Jeremy Davis's picture

Thanks for taking the time to report your experience. However, without knowing what the exact characters were (in your failed password, it's hard to know what the issue is and/or how to fix it. Also, when you say "[it] Wouldn't take my SYMBOLSupperlowercasenumbersSYMBOLS password" I'd be super interested in knowing exactly what the error message was!?

I have tried some random "special" characters (as I assume it's one of those that is the problem) but I've not been able to reproduce the issue so far. For me it "just works"?! That unfortunately means that I have no idea which character(s) are problematic so there is no pathway to improve things. Until I can get a hand, it sounds like it's going to continue to suck...

If you're willing to share your password more explicitly with me, that would be incredibly useful. If you don't want to post it publicly, that's fine, please feel free to contact me via the contact form and/or email support AT - if you email support, please also share context and/or link to this thread.

Donald Montaine's picture

The login to gitia 17.2 for administrative rights is "gitea" not "admin" as mentioned in the docs.  When you setup the system, the password you enter is applied to the gitea account.

Jeremy Davis's picture

Thanks Donald, your report is incredibly helpful.

FWIW I checked the Gitea appliance page, as well as the Gitea Readme (in the appliance build source code) and both of those note that the Gitea log in username is 'gitea'. So initially I was a little confused and wasn't sure what documentation you were referring to?

However, digging a little deeper, I noticed that the Gitea firstboot script (aka inithook explicitly asks the user to set the "Gitea 'admin' account" password and email address. Explicitly (currently lines 49 - 63):

    if not password:
        d = Dialog('TurnKey Linux - First boot configuration')
        password = d.get_password(
            "Gitea Password",
            "Enter new password for the Gitea 'admin' account.",
            pass_req = 8, min_complexity=4)

    if not email:
        if 'd' not in locals():
            d = Dialog('TurnKey Linux - First boot configuration')

        email = d.get_email(
            "Gitea Email",
            "Enter email address for the Gitea 'admin' account.",

So I'm assuming that's what you are referring to? Is it documented anywhere else that you are aware of?

I will address this now to ensure that it makes it into the upcoming v18.0 release. However, I note that there is an existing bug report regarding this issue (made by me... Doh!).

Add new comment