Slava's picture


I am following these instruction and used "Drush" and "Composer" methods:

This command ends with no errors: composer update drupal/core --with-dependencies

composer prohibits drupal/core:8.6.3 shows that there i sno dependencies

composer update drupal/core webflo/drupal-core-require-dev --with-dependencies ends with the word Killed

How can I update it???




Jeremy Davis's picture

In an attempt to as closely match what you have, I will try with the v15.3 release of our Drupal8 appliance. That one came with Drupal v8.3, (see the changelog entry) so I think that's a safe guess.

I'll have a try and post back ASAP.

Slava's picture

Thank you, Jeremy.

Yes, indeed,  this appliance was installed from turnkey-drupal8-15.3-stretch-amd64.ova



Jeremy Davis's picture

Starting with a v15.3 Drupal8 appliance Here's what worked for me:

cd /var/www/drupal8
# update composer itself - not sure if this is required, but can't hurt...
composer self-update
composer update drupal/core webflo/drupal-core-require-dev --with-dependencies
drush updatedb -y
drush cr

Note that on my install, ctools, google_analytics & pathauto are still outdated (although no security issues from what I can gather). So I also updated those like this (following on from above commands):

composer update drupal/ctools drupal/google_analytics drupal/pathauto

I'm not 100% sure, but I suspect that maybe the composer update is required? Please try that and re-run the update command (i.e. "composer update drupal/core webflo/drupal-core-require-dev --with-dependencies"). If you are still having issues with it, please try adding the "-v" switch to the "composer update" line. Then post back the output. I.e. run this command:

composer update drupal/core webflo/drupal-core-require-dev --with-dependencies -v
Jeremy Davis's picture

It's also well worth noting, that whilst doing the above, I got a root email (i.e. message that says "You have mail in /var/mail/root"). On reading that ("cat /var/mail/root"), it looks like the cron job is broken!

I've opened an issue and plan to fix that for the next release. However, I have also posted a fix.

To save you clicking the link, here's the fix:

sed -i "\|/usr/local/bin/drush| s|--|--root=/var/www/drupal8 --|" /etc/cron.hourly/drupal8

I recommend that you apply that fix ASAP so the cron jobs work properly.

Slava's picture

Hello Jeremy.

I ran the commands that you listed (seee the screenshot). But, upon running drush status command  it still shows Drupal version 8.6.3  Is there another step necessary?


Slava's picture

Additional info for you.

Running modules update:

Running Composer update with -V key:

Something is wicked in Drupal8 kingdom :(




Slava's picture

Jeremy, I found the root of the problem!

The default parameters of that VM are not sufficient for the upgrade: 512Mb of RAM and 1 CPU

I have increased RAM size to 2Gb and added extra CPU and the upgrade succeeded! It shows Drupal version 8.6.13

On to updating the modules...

Thank you for your help!

Sincerely, Slava

Slava's picture

Spoke too soon...

When I try to install a new module or a theme, I am getting this error:

"The website encountered an unexpected error. Please try again later"...

Jeremy, can you help with that, please?



Jeremy Davis's picture

Firstly, it seems a bit strange that the '-v' switch wasn't providing any additional output. In my experience, it should display much more than what you posted (including a stacktrace of the actual error encountered (at least mine did when I used the '-v' switch).

Regarding the modules you are trying to install, are you using drush or composer for that? If so, I suggest that you post any output that the commands you are trying are giving. It's also worth retrying the commands again with a '-v' switch. I'm not 100% sure that drush provides/honours a '-v' switch, but it does appear to have both '--verbose' and '--debug' switches ('--debug' being particularly verbose).

I don't think it's related, but FWIW when I initially tried the update (using 'composer update drupal/core --with-dependencies') that broke my Drupal instance (and I was getting a similar message). When I re-ran it with '-v', it gave a really verbose error which I googled and it turns out that there were some dependencies which had been updated, but weren't compatible with the older version of Drupal still installed. I downgraded that particular dependency and it all worked again. I then did some more reading/testing and discovered the need to also update 'webflo/drupal-core-require-dev'. Once I ran that (and re-installed the newer version of the dependency which I had downgraded), it all "just worked" again.

FWIW, I found additional info about the cause of the message I was seeing when browsing to the site, by checking the Apache error logs. I.e. try something like this:

tail -f /var/log/apache2/error.log

Then in your browser, go to the site. You should see an error come up in your log. Please feel free to post that back here if you want a hand with it.

So perhaps what I experienced is similar to your issue? Although, having said that, I suspect that it is more likely that there is an issue with one of the modules you have added. I would recommend removing them all again (or better still, restoring a backup from before you started this - assuming you have a backup?!). Then add them one by one until you can work out which one is causing the issue. Assuming that you can clarify that, you may be able to find reference to the bug, perhaps even find a workaround? If not, then at least you will be able to lodge a bug/contact the developer to see what else might be problematic.

Bottom line is that if you can assist me to recreate the issue, then I would likely be able to resolve it, or at least assist to locate where the issue exists. But without being able to recreate it, I'm only guessing.

Also if at all possible, when you post info from your server, rather than using screenshots, it's better if you can copy/paste the text. If you can't work out how, or it's too hard, I'll cope. But it's much easier for me to assist your search if I can copy/paste from your output, rather than have to retype it. :)

Jeremy Davis's picture

If so, that's fine. But if not, please let me know so I can try to help out.

Add new comment