steven webb's picture

i have a new install v 16.1-1 what is the default user name and pass,

i tried admin admin i tried admin and the password i used on the initial setup still no go.

 

PLease Help

Forum: 
Jeremy Davis's picture

The username is 'admin' and password set on first boot.

If that isn't working, then are you using a US-International keyboard? If not, some of the "special" characters (e.g. punctuation) may not be mapped properly when setting the initial password. If that's the case, then set the correct keyboard via Confconsole >> Advanced >> Region config >> Keyboard.

Then re-run the Zoneminder specific firstboot script:

/usr/lib/initihooks/bin/zoneminder.py
Jeremy Davis's picture

I just downloaded and launched a fresh v16.1 LXC instance on Promox. I set a password and log in as the Zoneminder 'admin' user "just works" for me?! TBH, I'm not super suprised as I had already tested the ISO and the LXC build is made by converting the ISO to an LXC template.

So assuming you are using a US-International keyboard (you didn't mention whether you are or not?!) then there is only one other possibility that occurs to me. That is that perhaps some specific character (or characters) that you've both included, don't work with Zoneminder for some reason (I've encountered that before with other appliances).

I would recommend re-running the Zoneminder script (as I posted above) and this time just use a password with upper case, lower case and numbers (no "special" characters like punctuation). I suspect one of them is the culprit...

Having said that, I have just tested 4 more random passwords that include "special" characters and they all worked?! FWIW, I tested these characters:

! @ # ( ) $

Perhaps one, or both of you could share the passwords that wouldn't allow login and I can test on my end?

Jeremy Davis's picture

Thanks for posting back. I really appreciate it.

I was trying to go to the urls mentioned for the app directly and assuming the same password had been set for all.

Do you mean the root password that you set within Proxmox? If so, I don't think that's possible? That is because AFAIK that is set outside the container and I'm pretty sure that it's only stored encrypted within the container. So the scripts that set the passwords, etc don't have access to the raw password. An encrypted password allows you to check if an entered password matches the stored password, but it doesn't allow you access to the raw password. If you have any info that suggests that my understanding my not be correct, I'd love to hear! :)

Also, for what it's worth, you shouldn't need to log in via SSH. Logging in via the Promox console should also work. Did you do that? Or did it only work for you once you had run it via SSH?

Add new comment