I tried to setup the Redmine Applicance and let me say that the LDAP Auth "just worked"

While trying to setup the Subversion repository though, it didn't work. I searched the forums but people had reported problems only as back as 2009 (Redmine + SVN).

I tried the "automatic WS" option as well, but that didn't work either.

* Would it possible to clarify in the UI itself what the URL exactly means (i.e. where the directory would get created for the different protocols).

Jeremy Davis's picture

I have no experience with the Redmine appliance but perhaps it may be useful to check with Remine docs/forums/etc?

Jeremy Davis's picture

Thanks for posting back! :)

As the current TKL appliance includes an upstream version of Redmine I suspect that the devs will again include the latest stable upstream version when they create the new v12.0 Redmine appliance.

Jeremy Davis's picture

So whether it is 3rd party may not be relevant. But this is something of a gray area AFAIK. Really as long as plugins are open source it shouldn't be a problem.

Having said that though, the only plugins that would normally make it into a TKL appliance would be ones that add useful functionality which the majority of TKL users would benefit from. I don't know whether an LDAP plugin would make it in under those conditions...

But assuming that adding plugins is relatively straight forward, then the TKL appliance should support it pretty easily I would hope.

Jeremy Davis's picture

There is a TKLPatch to upgrade TKL v11.x Redmine to the latest here. TKLPatch docs are here. Post if there's anything you're not sure about.

Add new comment