Michael Cole's picture

Hi guys, I'm trying to setup Redmine for a game programming club.

I'm trying to set it up on DigitalOcean, but after 4 hours getting nowhere.

I tried the docker images and didn't get anywhere.

I switched to "custom images" way to create a VM (DO Droplet).  I uploaded the Remine qcow2 and created a VM but cannot login.  

I'd also like to persist data in a volume /mnt/volume-nyc1-02/

I'm stuck after creating the VM that I cannot login.  

With SSH, I get Too many authentication failures

I can't see the initialization logs to get the password and DO's "email root password" says the image doesn't support that.  There is a mysql_d "String too long" error that flashes past.

How do I get this to work?  What's an easy self-hosting option (not AWS)?

Thank you!


Jeremy Davis's picture

When you say that you tried via Docker but that didn't work, I'm not clear what you mean?! I'm unfamiliar with DO (I know of them, but never used them) so I'm not sure whether they have some container service or something and that's what failed?! Or whether you had your own Docker host running on DO (or somewhere else?) and for some reason couldn't get it to work?! It's been a while since I've tested our Docker builds, but they worked fine last time I did...

You note that you then uploaded a qcow2?! Did you upload one of our OpenStack builds? Or did you build that yourself somehow? If you uploaded yourself, you could always download TKLDev and customise a build to suit your purposes?! Perhaps even include your SSH key OOTB?!

Re the "Too many authentication failures" - I'm not sure, but I suspect that is because our SSH config is a bit too locked down and/or perhaps our fail2ban rules are too aggressive too?! If you are using Linux (perhaps Mac too?), you can make the SSH client really verbose via the '-vvv' switch and that should hopefully give you insight into what is actually going wrong. I suspect that your SSH client is trying a few different keys and that is triggering the failure?! And/or perhaps fail2ban has blocked your IP?!

It's also perhaps worth noting that AFAIK, Digital Ocean requires cloud-init. We were looking at getting our images onto the DO Marketplace, but can't yet as that's a hard requirement. So perhaps that's part of the issue? FWIW cloud-init has become something of a standard in recent times, but unfortunately, its not something that TurnKey currently provides or supports. It's on our todo list, but that list is a mile long currently...

I do vaguely recall that DO used to have a way of launching/creating a VM from a "custom ISO". If that's still an option, then perhaps that's the way to go?

Finally, if you're getting nowhere with DO, then we have a list of Hosting Partners. I haven't checked in on them recently, so I'm not sure whether they are all still active and/or which versions of TurnKey they provide, but they might be worth having a look at them?!

Michael Cole's picture

Hi Jeremy, thanks for your very complete response.  I triend the "custom ISO" and didn't get anywhere.  Yes, it seemed like something wasn't working during the install.

I'll check out the hosting partners and see what's up.  Thank you!


Jeremy Davis's picture

Good luck with it all and please do not hesitate to post back with any further feedback, or if you continue to have troubles etc and I'll do my best to help out.

Michael Cole's picture

Ok, I'm setting this up for a game jam club and don't want to ask members to pay, so AWS priced out.

I originally tried the OpenStack image from here: https://www.turnkeylinux.org/redmine

I'm trying the VDMK, with DigitalOcean's caveats here: https://www.digitalocean.com/docs/images/custom-images/#limits

You mentioned customizing TKLDev.  I'm hoping to gain the work yall did in customizing the image.  Would I download the Redmine VDMK, customize in Virtualbox(?), then reupload?

I know a little docker/kubernetes and VirtualBox, but it's been awhile :-)

Thank you Jeremy, I'll keep posting updates here.



Jeremy Davis's picture

Ok, thanks for the additional info. It looks a bit like the issue you were hitting is cloud-init - as I suspected... :(

Re TKLDev, I won't go into too much detail here, but it's essentially our "build tool in a box". It's what we use to create all our images (and all the different build formats). You'd need to load that into a VM.

The build process uses a relatively simple, yet quite powerful step-by-step process which leverages Debian (and our own custom TurnKey) package repos, along with facility to overlay files (e.g. custom config files) and run configuration scripts. Mostly the conf scripts are bash, but they could really be any language supported by Debian - so long as it's preinstalled via packages (at the early part of the build process).

The main docs can be found on GItHub. Although there are likely omissions and I know that some of them are a bit out of date. Unfortunately, as per many open source projects, the docs are the last thing that gets updated...

If/when you're interested in building something and/or tweaking something that we already have, I'd love to assist you to get more intimate knowledge of TKLDev. Please just ask and I'd be happy to assist where I can.

Michael Cole's picture

Holy smokes!  I'm looking at the Webmin and this thing is amazing!  Your website way undersells what yall have created.  Thank you!

The "secret" on DigitalOcean was to create the image using the VMDK, with an emailed root password.  Then using Droplet -> Access -> Launch Console to complete.

That got me to the First boot wizard.

Thank yout!  This is so much nicer than the Bitnami one.


Jeremy Davis's picture

FWIW we don't make Webmin, we just package and pre-install it. Regardless, I agree it's pretty sexy... :) Although I must admit, that I'm more of a command line guy myself...

Ah ok, thanks for sharing what did the trick for you! I'm really glad to hear that you worked it out and got it up and running ok. :)

Thanks for your kind words and the favourable comparison to Bitnami. It must be all the love we put in! ;)

Also FWIW, shiny new appliance builds are on the way. I'm currently doing the final testing, bugfixing and general polishing and should be ready sometime real soon...

Michael Cole's picture

Hey Jeremy, thanks and looking forward to the builds. 

I gave up on Redmine for either Gitlab+svn-as-git or MantisBT+svnserve.  Once I got Redmine working there were a bunch of issues around automatic svn repo creation, and permission (everything was public, so not good for internet).  It needed alot more understanding than I wanted to give it.  GitLab and svn-as-git install via debian repos so might make a cool appliance.  https://bozaro.github.io/git-as-svn/htmlsingle/git-as-svn.html#_about

Really dig the appliance builds.  Thanks again Jeremy and good luck!

Jeremy Davis's picture

I thought that I'd already posted this but just noticed that I hadn't... So here it is.

Re Redmine; the repos are publicly available (by design) on our Redmine appliance (and other VCS appliances too). However, they should be read only unless authenticated (i.e. you shouldn't be able to push to them without authentication). If that's not the case, please let me know as that is a bug!

The rationale for intentionally making them public (read-only) is that we're an open source shop and encourage open source. Although perhaps we should at least better document how to make them private if desired?! I'd be interested in your thoughts.

Also I know it's been a little while now, but do you recall the issues re auto repo creation with Redmine? I vaguely recall that someone else reported issues with auto repo creation with Redmine. After I spent a bit of time investigating, it turned out that our appliance worked as expected and that it was the user's misunderstanding of how it was meant to work that was the issue (it didn't work the way they wanted/hoped/expected). But that was quite a while ago so perhaps something is now broken and/or there is new functionality which we don't yet support?

Also you seem pretty keen on SVN?! Is that because you are stuck with a legacy SVN repo? Or do you just not like git and/or prefer SVN? TBH, I've only had really limited exposure to SVN, but always found it clunky and painful...

Also FWIW we also have a GitLab appliance (installed via upstream "Omnibus" apt repo), plus a somewhat generic "Revision Control" appliance (which as per Redmine, includes both Git and SVN). My personal favourite VCS server though is our Gitea appliance (only provides git) - I use it myself and have an instance running on my local hypervisor as a local repo store. It's awesome IMO. :)

Re your other suggestions, as I note above, we already have a GitLab appliance. I'm not really clear on the value of svn-as-git?!

Michael Cole's picture

Hi Jeremy, thanks!  That's some good info.  I've got a development workflow with non-programmers working on binary files, so merge doesn't help.  The tools offer file locking for Subversion - I tried git for a bit, but Subversion really is a better work flow in the tools.  I've been working with GitLab and it's a monster!  Gitea appliance looks like a cool alternative.  Thanks!

Add new comment