TurnKey Linux Virtual Appliance Library

"make" missing from LAMP (2009.02-hardy) - can't install VMTools

vanarie's picture

(update: I previously did a test install on a Win08 server at home and didn't have a problem with apt-get as I am on a second install box with was setup by my hosting company. The second box has Win08 with 5 static IP addresses and no DHCP, so I'm thinking that this might be part of the problem. When I install, it often says "udhcpc No lease failing")

(update #2 - I think all I needed to do is run:

sudo apt-get update


and it looks like it fixed the "E: Couldn't find package kernel-source" problem. We'll see.)

I'm running into a snag in getting VMTools installed after installing on VMWorkstation 6.5.

I mounted the virtual cdrom and attempted to install VMwareTools-5.0.0-<xxxx>.i386.rpm

Ref. http://www.vmware.com/support/ws5/doc/ws_newguest_tools_linux.html

I'm doing the RPM (rpm -Uhv /mnt/cdrom/VMwareTools-5.0.0-<xxxx>.i386.rpm) method from the command line, but it's requiring "make" to compile it.

Here's a little on the site about how to set it up:

When I try "sudo apt-get install kernel-source", it returns:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package kernel-source

Not sure if I'm on the right path here. Got any suggestions?

Found this ref too: http://www.linuxforums.org/forum/debian-linux-help/56787-ubuntu-bash-com...


Liraz Siri's picture

You might find this article useful

It would be useful if could provide more information regarding the installation issues you are seeing on a network that doesn't support DHCP. If we can reproduce an issue we'll debug it and ship a fix when we release the next version.

Regarding VMware tools, personally I use VirtualBox rather than VMware for development and testing, but others have managed to install a TurnKey Linux appliance with vmware tools, and the process should be essentially the same as installing vmware tools on any Ubuntu 8.04 system.

Try reading this tutorial. Does that help?

Christian Peper's picture

add VMwareTools to Debian-based VMs using apt

If you run a Debian-based VM (such the JeOS TK VMs here), here is an easy way to install VMwareTools.
VMware has VMwareTools in a apt repo that you can add to the /etc/apt/sources.list and install using a simple 'apt-get install [vmware-tools|vmware-tools-nox]. The repo is at http://packages.vmware.com/tools

Here is what I did:
Get their GPG key
wget http://packages.vmware.com/tools/VMWARE-PACKAGING-GPG-KEY.pub
Add VMware's repo to your sources so apt can find it. It's easiest to create a new file for it.
vi /etc/apt/sources.list.d/vmware.list
Add the following lines. Make sure to match the correct ESX version you have. I don't know what happens if this does not match!
deb http://packages.vmware.com/tools/esx/3.5u4/ubuntu hardy main
deb http://packages.vmware.com/tools/esx/3.5u4/ubuntu hardy restricted
Next add the GPG key which should be in the directory where you downloaded it.
Update apt and install the VMware Tools. Use vmware-tools-nox to skip any X11/X.org related things, which you are probably not even using in your VM.
apt-get update
apt-get install [vmware-tools|vmware-tools-nox]
Hope this helps someone.

Liraz Siri's picture

Easier than compiling vmware tools from source

Thanks! This looks to be much easier to setup than compiling vmware tools from source. Very helpful.
Christian Peper's picture

when installing VMwareTools

one more thing... when you are going to VMwareTools, you may need some compile tools. To do that, just issue an
apt-get install build-essential gcc gnupg
This should give you make, gcc compiler and a way to check GPG sigs.

Then add the matching headers using
apt-get install kernel-headers-`uname -r`
Now you should be able to add VMwareTools using apt as shown above without any missing dependencies. if not, please report them here! :)

Edit: replaced the kernel version with `uname -r`. NOTE the right apostrophy there!!!

omearamd's picture

errors on install?

I followed the process above to use the vmware repo to install tools. HOwever, I got this message on install. Setting up vmware-open-vm-tools-common (7.4.7-0.158874.171375) ... Guest memory manager: failed Guest vmxnet fast network device: failed Blocking file system: failed Guest operating system daemon: done Anyone see similar results? Thanks, Mike
Christian Peper's picture

failed Guest vmxnet fast network device

Yes I have noticed similar notices but the network seems to work fine. I'm not sure what exactly is needed by VMwareTools. I'm currently playing with their repo and trying to find different install parameters if any, to see what happens and if these repo do anything different than using a VMwareTools*.tar.gz archive for installation.

Alinea's picture

What do I do if this

What do I do if this happens?

root@core:~# apt-get install kernel-headers-`uname -r`
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package kernel-headers-2.6.24-27-virtual
Jeremy Davis's picture


Sorry I didn't read through the thread to get the context of your question (which I really should've done). Also the below comments apply to TKL beta (based on Lucid/10.04) rather than the current TKL stable (based on Hardy/8.04).

That error can be caused by network issues or perhaps you need to run apt-get update or simply that the package isn't available (not sure why it wouldn't be as others seem to have used it successfully).

You could try:

apt-get install linux-headers-`uname -r`

But to be honest I don't think it'll do anything. It will merely tell you that it is already installed. If you want it to force a reinstall of the current kernel headers you will need to use the --reinstall switch. It should work like this:

apt-get install --reinstall linux-headers-`uname -r`

If you want to change your kernel headers, then do a search to find the desired package. You can either search online using Ubuntu package search, or use apt:

apt-cache search linux-headers

This will give you a list of all available kernel header packages.

[update] Corrected incorrect command to reinstall package (I mistakenly suggested the -f switch which is actually 'fix').
[update again] Scan rest of thread and realised I didn't understand the context of the question - Doh!
Jeremy Davis's picture

Hang on!

Sorry about this (I really should think and read properly before I post shouldn't I!) but if you are already running virtual headers then are you already using the VM build? (ie the zipped VM image as opposed to the ISO) If so it should have VMware tools already preinstalled! If you wish to update them then make sure the repo is added and simply use apt.

Guest's picture


I noticed this apt repo is for esx only.  Is there similar functionality for users of vmware-server2?

Jeremy Davis's picture

VMware tools is already installed in VM images

If you use the VM images rather than the iso, VMware tools is already installed. I have VMware Server 2 running on Win Server 2K3 at work and in the web interface it suggests that I am able to update it although I haven't tried yet. I will report back when I have.

Guest's picture


Hi ,

Do we have tklbam for RAW Centos. I am new for tklbam. Please Help\



Jeremy Davis's picture

TKLBAM is TKL only

Please see TKLBAM FAQ here.

Guest's picture

Thanks Bro

Dear Jeremy

Thanks for the update



Norris Ward's picture

Still can't get tools to start on Bugzilla appliance

Hi, I followed the above steps and Cannot get VMware-tools to compile.

I even installed apt-get install linux-headers-lbm-2.6.32-37-generic                                                                                                                                 

During the compile, I get these errors below.  What am I doing wrong?

Warning: Could not find /usr/lib/vmware-tools/configurator/udev/99-vmware-scsi-udev.rules or /etc/udev/rules.d.                                                                                                                                                                                                                                                                                             /sbin/ldconfig.real: Cannot mmap file /usr/lib/libDeployPkg.so.                                                                                                                                                                                                                                                                                                                                             /sbin/ldconfig.real: Cannot mmap file /usr/lib/libGuestLibJava.so.                                                                                                                                                                                                                                                                                                                                          /sbin/ldconfig.real: Cannot mmap file /usr/lib/libvmGuestLib.so.                                                                                                                                                                                                                                                                                                                                            /sbin/ldconfig.real: Cannot mmap file /usr/lib/libvmGuestLibJava.so.                                                                                                                                                                                                                                                                                                                                        /sbin/ldconfig.real: Cannot mmap file /usr/lib/libGuestLib.so.                                                                                                                                                                                                                                                                                                                                              Creating a new initrd boot image for the kernel.                                                                                                                                                      update-initramfs: Generating /boot/initrd.img-2.6.32-37-generic                                                                                                                                       .: 13: Can't open /scripts/casper-functions                                                                                                                                                           .: 6: Can't open /scripts/casper-functions                                                                                                                                                            .: 6: Can't open /scripts/casper-functions                                                                                                                                                            initctl: Job failed to start                                                                                                                                                                          Unable to start services for VMware Tools                                                                                                                                                                                                                                                                                                                                                                   Execution aborted.                          

Guest's picture

try uninstalling

try uninstalling canonical-casper package and then try..

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)