vuser1's picture


I downloaded MediaWiki appliance, in VMWare server did "Add VM to inventory". The appliance boots, VM-tools status is "running" and everything works OK, but instead of information about harddisk I see "Hard disk not valid". I tried to remove/re-add the disk to VM, it says disk is 20Gb, it adds it, but finally status is again "Hard disk not valid". But it works!

I noticed that "
Virtual Hardware Version" is 6 and updated it to 7. Still hard disk is not valid.

What did I wrong? Should I expect problems? Can I ignore this issue? 

Thank you!


vuser1's picture

No answer? Do appliances work on VMWare Server 2.0? 


Alon Swartz's picture

We will have to look into why the harddisk information is not displayed, but you can safely ignore the issue (to the best of my knowledge).
David Doom's picture

I am getting the exact same message "hard disk not valid" on the ProjectPier appliance on Vmware Server 2.X.

Although the appliance seems to work, I am concerned with its viability as a production worthy application with this error.

Jeremy Davis's picture

It sounds harmless to me, but if you are concerned about using it under these circumstance, download the iso and install from there.

Alon Swartz's picture

I figured out why VMWare server labels the hard disk as invalid, but firstly let me say that it is harmless.

The VMDK includes meta data, where the variable ddb.adapterType is set to null, where it should actually be set to the virtualDev specified in the vmx, which is lsilogic.

The fix is simple:

sed -i "s|ddb.adapterType = \"(null)\"|ddb.adapterType=\"lsilogic\"|" turnkey-app.vmdk

Also, for completeness, update the vmx to specify that the hard disk deviceType is a disk, though this should not be needed:

scsi0:0.deviceType = "disk"

You might need to unregister and reregister the VM for changes to take effect.

We will be releasing updated builds of all 2009.10 appliances including this fix, as well as the missing nic issue.

David Doom's picture

Is there a "simple fix" for the Windows Server....  (sed is obviously a unix command line utility)?


Alon Swartz's picture

You don't have to use workaround mentioned above as we have patched all VM builds, and re-released them. If you are using an older image that is effected, just re-download.
Pip Martin's picture


I am running VMWare server 2.0.2 203138 on MS Server 2008 R2 and one of my virtual servers has the 'hard disk not valid' message.

I have re-downloaded the file from the vmware site and tried to re-install it but it comes up with the message - dont use add/remove programs to repair this program, use the original file - which I am doing, so no help there. I have tried removing and re-adding the virtual machine but to no avail.

Please help.



Add new comment