Alex Rhys-Hurn's picture

Hi Folks,

Am enjoying this zimbra thingy but was wondering if there is anything special I should think about to upgrade it to the latest 6.0 zimbra release?

Can I just follow the instructions on



Liraz Siri's picture

I haven't tried this myself but you should give it a shot!

If you mess things up you can always go back to a clean, known-good installation. That's part of whats great about appliances. BTW, the next release of TurnKey Zimbra will be based on Zimbra 6.

If it works, drop us a line on the forums. Others may be interested in your experience!

Neil Bird's picture

Hi all, I decided, as a noob to linux to try my hand at upgrading.  What better way than to pick a project.

This is my method so far (credits to a couple of sources from Zimbra forums and this forum)

What I have done so far:

 Install turnkey zimbra

/usr/local/bin/zimbra-conf DOMAIN ADMIN_PASS
apt-get upgrade
apt-get update
chown root:root /tmp
chmod 777 /tmp
chmod +t /tmp
cd /temp
tar -xzf zc*
cd zcs-6.0.4_GA_2038.UBUNTU8.20091214184037
      ERROR: Installation can not proceeed. Please fix your /etc/hosts file to contain: <ip> <FQHN> <HN>
mod /etc/hosts  localhost mail

again ...

cd zcs-6.0.4_GA_2038.UBUNTU8.20091214184037


  ERROR: Installation can not proceeed.  Please fix your /etc/hosts file  to contain:  <ip> <FQHN> <HN>  Where <IP> is the ip address of the host,   <FQHN> is the FULLY QUALIFIED host name, and  <HN> is the (optional) hostname-only portion

 ... should I have tried it with just the default example domain... I am not completely sure what the upgrade is expecting by way of formatting/ability to resolve the name.

During the process of upgrading I do get the indications that an upgrade will happen... Seems close but I am curious what I need to fix.  I do have active mx records to resolve

Hope this is detailed enough for guidance... maybe it is just too late at night :)

Neil Bird's picture

Well, after serching the zimbra forums, this is apparently quite common, and I find oddly not considered a bug.

Although I was testing this, I did try my live ip and hostname.... and removing, not commenting out the ip6 lines.

This and only this in hosts file allowed the upgrade to proceed.  localhost.localdomain localhost
xx.xx.xx.xx  mail
no extra spaces, lines etc.
Will replace all removed lines later... and will possibly re-run the custom script to change domain... just to be thorough I suppose.
Neil Bird's picture

I ran the upgrade twice after the initial prep.

They both failed with this.


Upgrading from  to 6.0.4_GA_2038

Stopping zimbra services...done.

Verifying /opt/zimbra/conf/my.cnf

Starting mysql...done.

I can't upgrade version



So I have decided to not upgrade... as I had nothing to lose on this test box.  As you said, nice to go back to a known working appliance :)


I will test this "upgrade" as it looks to have installed ok.  However, I am curious if anyone smarter than I is interested in trying this upgrade.  I might just go to the core server and install, however, I like the benefits of the appliance, but think that a viable upgrade is worth trying to sort out.


Cheers! ... will post back later if I stuck with this or moved to the core.  The core makes sense as In the process of doing a full install any mail and users were deleted.

Jonathan Carroll's picture

Another confirmed upgrade here, I was doing a "cold steel" install and I am writing a tutorial/description of what I had to do to get it working on a home-network.  

I still have a DNS issue that may never be resolved because of a Dynamic Domain, and the conflict with Postfix/Hosts file.  Seems that it wants a static IP for receiving emails.  The problem is documented on the zimbra forums, but with no fix from dynamic home users stand-point.  

I have created a low tech workaround that will be described in the tutorial.  It utilizes a php mailbox on the Windows machine that has the Dynamic DNS update client.  So mail is retrieved by Zimbra via an external POP account that has the same account name and password as the primary account.  

It has the unfortunate issue of being work intensive for creating new accounts, but since this server is only for my friends and family it is sufficient for home use/serving.  You can view a Web Log of the process at: which is also on another homeserver. 

Also I never had to use the sysstat edit/workaround.  (ENABLED="false" to ENABLED="true")

Good work working out a complete solution!

Jonathan Carroll's picture

Completed an upgrade from 6.0.5 tonight.  Cold Steel Installation!!!!!!! My BIND conf is still jacked up cause of dynamic dns, but with the workaround everything is functioning as good as it ever was.  ***see post above*** 


download the Ubuntu 8.x 32bit ***last 32 bit OS supported :(  ***

Also down load the release notes it has important info on the Documents and webex integration aswell as instructions for installation. 

"apt-get install sqlite3" <--- new package needed for Zimbra 7

then push installer package to server <---- I used the file manager in the webadmin cause it will unpack and run while you cook dinner Shell in a box may time out. 

"cd /opt/upzim/zcs-7.0.0_GA_3077.UBUNTU8.20110127201433"

 ***/upzim is the dir i create to push upgrades you don't have it on you system***


follow prompts till end.  If you are missing a package make sure you exit and get it!  

I completed this upgrade in about an hour.  It took a very long time to shut down services and start the upload, but man is it a pretty upgrade. 

Have fun!!!!!

Jeremy Davis's picture

Technically Zimbra 7 is not supported on Ubuntu 32 bit though, so you may be out of luck.

Add new comment