TurnKey Linux Virtual Appliance Library

Redmine email notification fix = Solved

tsokolis's picture

Running Redmine 12.0.1 on Proxmox VE 2.1.14, Postfix email notifications did not work for me out of the box.

image = debian-6-turnkey-redmine_12.0.1_i386
  • SSH'ed to the appliance
  • cd /var/www/redmine/config/
  • nano configuration.yml
  • made changes below and saved

Original:

production:
 email_delivery:
   delivery_method: :smtp
   smtp_settings:
     address: "localhost"
     port: 25

Changed to:

production:
 email_delivery:
   delivery_method: :sendmail
   smtp_settings:
     address: 127.0.0.1
     port: 25

Now working

Reference post at redmine.org http://www.redmine.org/boards/2/topics/6641

Thanks for the great work on these images

Jeremy Davis's picture

Thanks for reporting

And bonus points for providing a fix! :)

I've lodged it as a bug here.

Guest's picture

Didn't work for me

I tried this but still am not getting emails out.  Are there settings changes required in PostFix itself or the firewall perhaps?

Jeremy Davis's picture

Check your firewall (if you

Check your firewall (if you have one). The TKL firewall shouldn't be an issue (unless you've enabled it, and even then AFAIK it should already have an exception configured OOTB). Also if you are running your server locally (VM or baremetal) sometimes ISPs will block email sending - so contact them and check if that's the case, and if so if there is a workaround (perhaps you can relay through their SMTP).

If using AWS/Hub then I think often Amazon blocks emails. IIRC Chris put something in the docs about that...

Guest's picture

does not work

Hi, I also have redmine turnkey v12, I upgraded to the latest redmine according to instructions elsewhere on this forum. Everything works except email.

I used the configuration.yml above and it does not work.

Do I need to configure something else in postfix? or in redmine?

Thanks for your suggestions

Guest's picture

It's working

After adding the below line in the configuration file, it worked for me

openssl_verify_mode: 'none'

source: http://www.redmine.org/boards/2/topics/30851

Guest's picture

Hi,   I am sure that i use

Hi,

  I am sure that i use the same code in config/configuration.yml

production:
 email_delivery:
   delivery_method: :sendmail

when i am sending a mail for test, redmine gives a notification that "an email has been sent to user@gmail.com" but when i check in gmail, there is nothing, also see in trash and spam too. There i found nothing. Please help me to recover the problem.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)