Justin's picture

I followed the documentation on the GitHub page, but everytime I try to make the core I get errors.

root@tkldev ~# cd /turnkey/fab/products/core/
root@tkldev products/core# make
deck -D build/bootstrap
deck /turnkey/fab/bootstraps/wheezy build/bootstrap
Traceback (most recent call last):
  File "/usr/lib/deck/wrapper.py", line 18, in <module>
  File "/usr/lib/python2.7/dist-packages/pyproject.py", line 388, in main
    commands.run(name, args)
  File "/usr/lib/python2.7/dist-packages/pyproject.py", line 261, in run
  File "/usr/lib/deck/pylib/cmd_deck.py", line 128, in main
    func(source_path, new_deck)
  File "/usr/lib/deck/pylib/deck.py", line 299, in create
    Deck.init_create(source_path, deck_path)
  File "/usr/lib/deck/pylib/deck.py", line 215, in init_create
  File "/usr/lib/deck/pylib/deck.py", line 246, in mount
    aufs.mount(levels, self.path)
  File "/usr/lib/deck/pylib/aufs.py", line 35, in mount
    command("useraufs-mount", "--udba=reval", path, *branches)
  File "/usr/lib/python2.7/dist-packages/executil.py", line 66, in getoutput
    raise ExecError(command, exitcode, output)
executil.ExecError: non-zero exitcode (1) for command: useraufs-mount '--udba=reval'  'build/bootstrap'  '/turnkey/fab/products/core/build/.deck/levels/3674988187acee5a585bc7f0377f519a'  '/turnkey/fab/bootstraps/wheezy'
mount: block device none is write-protected, mounting read-only
mount: cannot mount block device none read-only
fatal: non-zero exitcode (32) for command: mount -t aufs -o 'dirs=/turnkey/fab/products/core/build/.deck/levels/3674988187acee5a585bc7f0377f519a:/turnkey/fab/bootstraps/wheezy,udba=reval'  'none'  'build/bootstrap'
make: *** [build/stamps/bootstrap] Error 1

What do I do?

Justin's picture

As mentioned in this post, I think my problem is using OVZ. I will reinstall with KVM.

EDIT: Yup, don't use OVZ

Justin's picture

I still get an error as described here. I tried the solutions listed in that thread, but I still can't get it to work.

could not find Kernel Image:  gfxboot

What do I do now?

Jeremy Davis's picture

Hopefully in the future we'll refactor TKLDev so it can run as a container (e.g. in OVZ or LXC) but for now we're stuck with that limitation...

As for your ISO not bootable issue that's new to me... I have been building many (many, many) ISO during the development of v14.0 and have never come across that issue... Landis (Arnold - from that thread) appears to have not had that issue since although he doesn't clearly state what resolved it, so perhaps just make sure you are using the default TurnKey git branches (master) and update everything (tkldev-setup) and try rebuilding from scratch (i.e. make clean && make).

Otherwise are there perhaps any specific changes you are making?

I guess if you can share what you are actually doing/trying to achieve perhaps I can help?

Justin's picture

I don't have a tkldev-setup. I assume we're talking about this? I looked in that directory and the folder was empty. I created it manually however.

Justin's picture

I ran the tkldev-setup that I created, cleaned make, restarted and got more errors.

E: Unable to locate package isolinux
Traceback (most recent call last):
  File "/usr/lib/fab/wrapper.py", line 34, in <module>
  File "/usr/lib/python2.7/dist-packages/pyproject.py", line 388, in main
    commands.run(name, args)
  File "/usr/lib/python2.7/dist-packages/pyproject.py", line 261, in run
  File "/usr/lib/fab/pylib/cmd_install.py", line 129, in main
    installer.install(packages, ignore_errors)
  File "/usr/lib/fab/pylib/installer.py", line 267, in install
    self._install(packages, ignore_errors)
  File "/usr/lib/fab/pylib/installer.py", line 137, in _install
    self.chroot.system("apt-get", *(args + packages))
  File "/usr/lib/python2.7/dist-packages/chroot.py", line 80, in system
  File "/usr/lib/python2.7/dist-packages/executil.py", line 56, in system
    raise ExecError(command, exitcode)
executil.ExecError: non-zero exitcode (100) for command: chroot '/turnkey/fab/products/core/build/root.build'  'sh'  '-c'  "env -i  'TERM=xterm'  'AMD64=y'  'DEBIAN_FRONTEND=noninteractive'  'HOSTNAME=core'  'WEBMIN_FW_TCP_INCOMING=22 12320 12321'  'FAB_ARCH=amd64'  'DEBIAN=y'  'FAB_HTTP_PROXY='  'DEBIAN_PRIORITY=critical'  'HOME=/root'  'RELEASE=debian/wheezy'  'PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/bin:/usr/sbin'  'CODENAME=wheezy'  'LC_ALL=C'  'DISTRO=debian' apt-get 'install'  '--force-yes'  '--assume-yes'  'libgcc1'  'lsb-base'  'kbd'  'iproute'  'libreadline6'  'findutils'  'rsyslog'  'sensible-utils'  'libusb-0.1-4'  'systemd'  'libncursesw5'  'whiptail'  'less'  'sysv-rc'  'shellinabox'  'libapt-pkg4.12'  'iptables'  'libpam-modules'  'liblzma5'  'gcc-4.7-base'  'cpio'  'bash-completion'  'libacl1'  'debian-archive-keyring'  'ssh'  'libncurses5'  'readline-common'  'util-linux'  'acpi-support-base'  'libpam0g'  'bind9-host'  'webmin-updown'  'stunnel4'  'sysvinit-utils'  'webmin'  'psmisc'  'libslang2'  'e2fslibs'  'tklbam'  'net-tools'  'hubdns'  'udhcpc'  'debconf'  'libpam-modules-bin'  'casper'  'syslinux-common'  'webmin-passwd'  'libudev0'  'udev'  'cron'  'sed'  'mktemp'  'kmod'  'rsync'  'localepurge'  'nano'  'inithooks'  'libselinux1'  'ncurses-bin'  'webmin-net'  'libpam-runtime'  'libss2'  'ntp'  'screen'  'libmount1'  'libattr1'  'webmin-useradmin'  'wget'  'libbz2-1.0'  'bash'  'webmin-custom'  'mawk'  'sysvinit'  'di-live'  'webmin-software'  'python-dialog'  'webmin-file'  'login'  'libklibc'  'etckeeper'  'lvm2'  'gpgv'  'apt'  'lsb-release'  'libc-bin'  'syslinux'  'ifupdown'  'webmin-sshd'  'cron-apt'  'tzdata'  'webmin-syslog'  'netbase'  'turnkey-sysinfo'  'git-core'  'libustr-1.0-1'  'libsepol1'  'traceroute'  'turnkey-version'  'libsemanage1'  'bsd-mailx'  'webmin-theme-stressfree'  'libcomerr2'  'hdparm'  'debianutils'  'bsdutils'  'webmin-tklbam'  'ncurses-base'  'confconsole'  'iputils-ping'  'dash'  'grep'  'mount'  'initscripts'  'resolvconf'  'gnupg'  'libdb5.1'  'procps'  'ethtool'  'turnkey-pylib'  'tar'  'man-db'  'libsemanage-common'  'libprocps0'  'logrotate'  'unzip'  'file'  'base-files'  'curl'  'initramfs-tools'  'dpkg'  'libtinfo5'  'hostname'  'coreutils'  'libstdc++6'  'libkmod2'  'webmin-shell'  'insserv'  'passwd'  'webmin-text-editor'  'webmin-postfix'  'multiarch-support'  'gzip'  'zlib1g'  'libc6'  'webmin-firewall'  'klibc-utils'  'eject'  'postfix'  'diffutils'  'ncurses-term'  'isolinux'  'e2fsprogs'  'base-passwd'  'monit'  'perl-base'  'locales'  'vim-tiny'  'webmin-lvm'  'libblkid1'  'libuuid1'"
make: *** [build/stamps/root.build] Error 1
Jeremy Davis's picture

I'm not sure why you are encountering all these issues but it seems like your TKLDev is broken... TBH I would probably re download and start again.

FWIW this blog post might be worth a read. It probably covers stuff you have already done but perhaps the step-by-step might help you out?

Justin's picture

That guide did work. It should be noted that I was using the v13 tkldev from the list of apps, not the v14rc1 on that page. Thanks a bunch Jeremy!

Jeremy Davis's picture

I should have thought of that sooner! You got there in the end though. :)

Add new comment