Hi folks,

I have justed install Redmine TKL v14.0 (on ESXi 6.0 host), but am unable to access the Redmine site (both HTTP and HTTPS).

But apart from the Redmine web site, everything else works, that is, web shell, webmin and ssh.

Can someone please provide some pointers?

Thanks in advance!

 

Cheers, Arthur

 

 

Forum: 
Jeremy Davis's picture

AFAIK it should work with most modern browsers but perhaps it's worth trying a different one just in case?

FWIW I just downloaded and installed the Redmine appliance (under KVM in Proxmox - but that should be irrelevant) and the Redmine bit itself works fine for me.

Perhaps it's worth checking to see if Apache is running:

service apache2 status
It should be "active (running)". If it's "inactive (dead)" then try starting it:
service apache2 start
If it's "active (exited)" then I suggest you check the Apache log (/var/log/apache2/error.log) for errors...

Hi Jeremy,

Indeed, it's due to Apache not being active.  Output from service apache2 status:

 

root@redmine ~# service apache2 status

* apache2.service - LSB: Apache2 web server

   Loaded: loaded (/etc/init.d/apache2)

   Active: failed (Result: exit-code) since Sat 2015-10-17 08:08:49 UTC; 5s ago

  Process: 11868 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

Oct 17 08:08:49 redmine apache2[11868]: Starting web server: apache2 failed!

Oct 17 08:08:49 redmine apache2[11868]: The apache2 configtest failed. ... (warning).

Oct 17 08:08:49 redmine apache2[11868]: Output of config test was:

Oct 17 08:08:49 redmine apache2[11868]: AH00526: Syntax error on line 38 of /etc/apache2/conf/redmine_webaccess.conf:

Oct 17 08:08:49 redmine apache2[11868]: RedmineDbPass takes one argument, RedmineDbPass command

Oct 17 08:08:49 redmine apache2[11868]: Action 'configtest' failed.

Oct 17 08:08:49 redmine apache2[11868]: The Apache error log may have more information.

Oct 17 08:08:49 redmine systemd[1]: apache2.service: control process exited, code=exited status=1

Oct 17 08:08:49 redmine systemd[1]: Failed to start LSB: Apache2 web server.

Oct 17 08:08:49 redmine systemd[1]: Unit apache2.service entered failed state.
Line 38 of /etc/apache2/conf/redmine_webacces.conf:
  RedmineDbPass ""

After updating this to "password" (I got this from Googling), I was able to restart apache successfully and the Redmine site now works.

This is indeed weird as I have not edited the redmine_webaccess.conf, in fact I have not manully changed anything.

Thanks for your help!

 

Cheers, Arthur

 

 

Jeremy Davis's picture

My guess is that for some reason either the inithooks didn't run properly or failed for some reason. Maybe your ISO was corrupted (just ever so slightly) during download?

For future reference initialisation can be re-run with

turnkey-init
Rasha Morgan's picture

Hi Arthur,

Thank you so much, I had the same problem, did your fix and it is working now.

 

Thank you so much

Jeremy Davis's picture

I have tried to reproduce this issue (so I can fix it) but I haven't been able to so far!?

Could either/both of you please give me some more info about where/how you are running the TurnKey Redmine appliance so I can try to pin the problem down and fix it!?

Jeff's picture

For the record: I get exactly the same problem (RedmineDbPass is empty). Manually editing the conf file does allow apache2 to start.

Redmine was installed from turnkey-redmine-14.0-jessie-amd64.ova (downloaded this afternoon) and installed in ESXi 6.

Re-running turnkey-init does not improve anything.

Installing was pretty straightforward: entering passwords (for root, mysql and redmine admin), setting two e-mail addresses, skipped the API-key and running the initial security updates.

As I created a snapshot just before initial boot I did a rollback and restarted the whole process with the same results.

Is there a logfile I can examine? I'd be happy to do another rollback/restart, just playing around anyway.

Jeremy Davis's picture

I will need to have another look. Perhaps I resolved this locally (during development) and forgot to push it back to the TurnKey repo? For the record I have been using the ISO that I built during the testing stage; prior to v14.0 public release. In theory it should be the same as the public builds; but as someone (I forget who) said: "In theory; theory and practice are the same. In practice that's not always the case... "!

When I get a chance I'll download and check properly! For now I have lodged a bug on our issue tracker.

Donald's picture

 

Hi

It looks to me if it's an update issue causing configuration changes.

If I build the appliance, go through the setup and NOT install the updates I can log into the Redmine home page with out any issue.

If I leave the appliance for 5 minutes and reboot it no longer works.

I notice that at least /etc/apache2 folder contents is completley changed from initial startup.

I built it from the ISO I downloaded last week, I see the OVA is available now so I'll try and build that just to see if it has the same issue.

Cheers

Donald

Donald's picture

 

Hi 

Ignore some of my last post.

"I notice that at least /etc/apache2 folder contents is completley changed from initial startup" this isn't the case, I got mixed with an old folder copy I have.

I have tried the OVA and it has the same issue, on initial startup Apache2 starts fine, reboot the appliance and it no longer starts.

Thanks

Donald

Manually adding the dB line works for general redmine webpage access, but there is something else wrong with the apache configuration preventing API access to Redmine.

I have been trying to get the 

/var/www/redmine/extra/svn/reposman.rb

script to run. Evaulating the error logs, I discovered a /etc/cron.d/redmine task had already been configured, and failing every minute (installed by default).

* * * * * root ruby $WEBROOT/extra/svn/reposman.rb --redmine localhost --svn-dir /srv/repos/svn --owner www-data --url file:///srv/repos/svn --key-file $WEBROOT/api_key 2>&1 >> /var/log/reposman.log

lines from the /var/log/reposman.log file match errors from manually running the script.

No project found, perhaps you forgot to "Enable WS for repository management"
Request was denied by your Redmine server. Make sure that 'WS for repository management' is enabled in application settings and that you provided the correct API key.

Double checking the settings in redmine confirmed that WS is enabled.

/var/logs/apache2/error.log shows entries for

AH01630: client denied by server configuration: /var/www/redmine/public/sys

Most common cause of the error according to google are bad .conf files for apache (not upgraded between 2.2 and 2.4). Changed /etc/apache2/conf/redmine.conf from "Order allow,deny\nAllow from all" to "Require all granted"

Ran "service apache2 restart" successfully starting apache, but access errors remain. Any further guidence or help would be greatly appriciated in resolving these issues.

Jeremy Davis's picture

I have reproduced the error (as others mentioned it only shows after reboot) but I'm pretty sure I know how to fix that (permanently/properly). We will look to re-release.

Thanks also for reporting this new bug. I will treat this as a separate issue but will certainly see if I can resolve this too! My initial guess (backed by no research at all) is that it may be permissions related? I will see if I can reproduce this one and see how we go...

Jeremy Davis's picture

It was a broken inithook causing this issue. It was only showing itself once Apache was restarted (hence the problem occurring only after reboot). We will rebuild this appliance so that it has a randomly generated MySQL password.

The fixed code is here for those that are interested (I renamed the script too).

I have opened a new issue for the API problem which Brian mentions above. I do not yet have a fix for that.

Jeremy Davis's picture

It replaces the old one and it should have propagated across our mirror network by now.

Add new comment