Etienne Moureton's picture



I'm trying to install locally on VirtualBox (OVA) but at init it asks for us a password for the avideo 'admin' user. I set it (it is the same as the one i set for SQL or Adminer) but at the moment to log in, the shell, i always have "Login incorret". All others passwords are well set up (I can access database & adminer).



Jeremy Davis's picture

The username should be 'admin'.

Also, are you using a US-International keyboard? If not, perhaps some characters are being interpreted differently between VirtualBox and your web browser (seems unlikely if Adminer access is working)? Even if you are using a US-International keyboard, then perhaps there are some characters in your password that aren't working with Avideo (but aren't explicitly blocked)? The characters most likely to cause issue are quotes (single and double), dollar sign and parentheses (aka "round brackets").

For what it's worth, you can re-run the all the firstboot scripts like this:


Or just re-run the Avideo script alone, like this:


I've got some other stuff to take care of, but please post back and let me know how you go. If you can't get it working (and can confirm that you checked the other stuff I mentioned) then I'll try to launch an instance myself tomorrow to see if I can reproduce the issue. If I can, I'll develop a fix ASAP.

Thanks for taking the time to report, and sorry that it didn't "just work" like it should!

Etienne Moureton's picture

Thanks for the quick reply, really appreciate it. It seems that the shell finally asked for the root user login. So it wasn't 'admin' as login but 'root', was fully a misunderstanding.

I have another question that might be stupid but : as I don't have a specific domain for my use, I just want it accessible though my network with IP, how can i remove the apache config that redirect to an obligated IP/domain set in the init ?



Jeremy Davis's picture

All good! You just caught me before I left my desk (and here I am back at it again...).

So yeah, as per the notes on the Avideo appliance page:

Username for AVideo (and AVideo encoder):

Login as username admin

Username for database administration:

Adminer; login as MySQL username adminer: - Adminer database management web app

MySQL command line tool; log in as root (no password required):
$ mysql --user root
Welcome to the MySQL monitor. Commands end with ; or \g.
Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

Username for OS system administration:

Login as root except on AWS marketplace which uses username admin.

Out of interest, did you see that and misunderstand it? Or didn't see it, or something else? Looking at it myself, it is a little convoluted. I wonder if there is a way that we can make it clearer?! If you have any suggestions, I'd love to hear...

Re your new question, I suggest setting the IP address as the "domain". That is because Avideo itself actually uses the "domain" internally. You may be able to remove the redirect to https though (otherwise you'll need to click through the self signed https cert warning)? TBH, I forget if Avideo uses the schema (i.e. the http:// or https:// bit) internally or not? Have a go and see how it goes. If it doesn't work, then let me know and I'll have a look and see how we can make it default to unencrypted.

Add new comment