Digitalchild's picture

Hi everybody,

I started to replace all of my servers in my datacenter with containers, due to enhanced security, speed and ease of maintenance.

In order to replace my plex mediaserver, I tried to download your media appliance, with Jellyfin but I'm facing with a strange issue.

I tried to copy from my old debian VM the /etc/fstab file containing the info to mount all the smb shared son my nas but I always get a permission denied error.
Then I tried to mount it manually, installing cifs-tools: same result.
Then I tried to mount using the webmin interface coming with turnkey linux: same result.  

Trying to mount smb/cifs shares and even nfs4 shares, same results. Operation not permitted.
Is there any way to address this and let me mount the shares containing all my media and let jellyfin and plex run?

I think that this is not a problem of cifs/nfsv4 parameters, since these shares are mounted on other debian VMs, I guess that this is a security related of turnkey linux container.

I tried also to delete my container and to rebuild it from scratch, but same results.
Thanks in advance for your support.


Jeremy Davis's picture

It appears that you've hit the limitation of CIFs (actually any filesystem that leverages FUSE) within an unprivileged container. You can't mount remote CIFS (or other FUSE based) shares directly... It's a limitation of unprivileged containers, rather than anything to do with TurnKey.

IMO you have a few options that I can think of:

  • Run your Mediaserver as a "proper" (i.e. more isolated and less restricted) VM.
  • Mount the CIFS share on the host and then pass them through to the guest container via host configured mounts.

There's probably other options too, but they're my top 2 "go to"s.

Add new comment