Ernesto Zavala's picture

Hello Friends

Please give me a hand.

I just installed Turnkey OTRS using ISO file (both versions  "V16.1 445MB ISO" and "V15.1 371MB ISO") over Virtual box on Windows 10 Pro 64x.

I made installation using the most simple and basic password for root in order to avoid any typing error. Even so my first try to log in to the new OTRS installation failed.

I tried admin, root, otrs, admin@localhost, root@localhost, otrs@localhost to access "https://My-Ip/otrs/" but I could not log in.

Please if anybody can help me with a step by step explanation of how to solve this issue (Because english is not my native language) I will be gratefull.

Regards and be safe

Jeremy Davis's picture

I can't be sure, but it sounds like you are having troubles logging into the OTRS web UI? If so, then according to the the OTRS appliance page, the username should be 'admin' (and the password you set at firstboot). Having said that, I note that on the build code Readme it states that the username should be 'root@localhost'?! So I'll double check myself and update whichever is incorrect.

Regardless, the password you set for the 'root' Linux user account should work for log in via SSH, Webshell (web based shell accessible via https on port 12320) and Webmin (web based server admin UI via https on port 12321).

So, I've now launched a new OTRS instance and can confirm that the OTRS admin username is indeed 'root@localhost" (and password set at firstboot). I just tested with a fairly simple password and it "just worked" (accessing ; username root@localhost, password set at firstboot). One thing you could try is reboot and re-run the firstboot scripts:


Or alternatively, you could just rerun the OTRS specific question:


After setting the OTRS password and email, you should see "Successfully set password for user 'root@localhost'." in green (it will flash by if you run 'turnkey-init', but should be easily visable if you run just the OTRS hook).

The only other thing that occurs to me is perhaps you are using a non-US International keyboard?! If that's the case, either try to keep the password as simple as possible, being especially careful with "special characters"; or pre-configure your keyboard. If you try the simple password route (again), then be careful to ensure that the keys you use map the same for your keyboard vs US international.

Alternatively, if you want to configure your keyboard, you can do that via Confconsole >> Advanced >> Region Config >> Keyboard (feel free to also set Locale and Timezone). Be sure to change your root password immediately too (via 'turnkey-init if you want to reset everything; or 'passwd' to just reset the Linux user password). Before you log out of your current shell session, double check that you can log in ok in a new SSH session (be sure to leave the current session open, so you can try resetting the password again if it initially doesn't work). Once you've done that, retry resetting the OTRS password again and fingers crossed it will "just work" for you too!

PS thanks again for posting as you've prompted me to update the OTRS applinace page to ensure that it has the appropriate info. I've also removed the link to the old v15.x version as it's really out of date.

Ernesto Zavala's picture

Dear Jeremy

You are right, I was swapping account and password.

Finally it worked using root@localhost and the intial password.

Shame on me!!!!

But give peace know that you are here for help.

Really thanks.

(Excuse my english, is not my native language)

Jeremy Davis's picture

Good luck with it all. And please don't hesitate to drop in if you have any further questions or feedback for us! :)

Add new comment