TurnKey Linux Virtual Appliance Library

magento error

renareto's picture


I've installed magento on VirtualBox pc.

when I access (from host) the guest pc, I receive thie error:


Exception printing is disabled by default for security reasons.

Error log record number: 177749780


what does it mean?

what I can do?




Jeremy Davis's picture

Not sure if the same problem

But you may find something of interest on this forum topic.

Guest's picture

Same issue

Any more updates on this error?  I've tried running a copy of magento using multiple pc's and different install paths (iso, vm, etc) and get this type of error EVERY time.  I've tried to NOT do the suggested security updates also and still getting this kind of error.

Exception printing is disabled by default for security reasons.

Error log record number: 177749780 (error log # changes each time)

 I'm currently running the latest version of VirtualBox.

Any suggestions would be welcome... it's making me a little nuts!

Jeremy Davis's picture

To troubleshoot you'll need to enable error reporting

From my understanding Magento has proper error reporting disabled by default (supposedly a security feature...?) As I mentioned in the other TKL thread (that I linked to above) if you wish to work out exactly what is going on you'll first need to enable proper error reporting. There is a link to a page that I think would be useful on the other thread but for your convienience here it is again.

Good luck and if you get it worked out, it'd be great if you can post back.

Guest's picture

Same Issue

Installed on a microserver on EC2 TurnkeyHub deployment the same error occurs on first connection to the server, the error in the error log is as below...

I have been throught the various threads and need help to get a server running...


a:4:{i:0;s:85:"SQLSTATE[42000]: Syntax error or access violation: 1286 Unknown table engine 'InnoDB'";i:1;s:1589:"#0 /var/www/magento/lib/Zend/Db/Statement.php(300): Zend_Db_Statement_Pdo->_execute(Array)

#1 /var/www/magento/lib/Zend/Db/Adapter/Abstract.php(468): Zend_Db_Statement->execute(Array)

#2 /var/www/magento/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query('SELECT `core_ca...', Array)

#3 /var/www/magento/lib/Varien/Db/Adapter/Pdo/Mysql.php(333): Zend_Db_Adapter_Pdo_Abstract->query('SELECT `core_ca...', Array)

#4 /var/www/magento/lib/Zend/Db/Adapter/Abstract.php(782): Varien_Db_Adapter_Pdo_Mysql->query(Object(Varien_Db_Select), Array)

#5 /var/www/magento/app/code/core/Mage/Core/Model/Mysql4/Cache.php(49): Zend_Db_Adapter_Abstract->fetchPairs(Object(Varien_Db_Select))

#6 /var/www/magento/app/code/core/Mage/Core/Model/Cache.php(424): Mage_Core_Model_Mysql4_Cache->getAllOptions()

#7 /var/www/magento/app/code/core/Mage/Core/Model/Cache.php(459): Mage_Core_Model_Cache->_initOptions()

#8 /var/www/magento/app/code/core/Mage/Core/Model/App.php(1101): Mage_Core_Model_Cache->canUse('config')

#9 /var/www/magento/app/code/core/Mage/Core/Model/Config.php(404): Mage_Core_Model_App->useCache('config')

#10 /var/www/magento/app/code/core/Mage/Core/Model/Config.php(286): Mage_Core_Model_Config->_canUseCacheForInit()

#11 /var/www/magento/app/code/core/Mage/Core/Model/App.php(359): Mage_Core_Model_Config->loadModulesCache()

#12 /var/www/magento/app/code/core/Mage/Core/Model/App.php(295): Mage_Core_Model_App->_initModules()

#13 /var/www/magento/app/Mage.php(596): Mage_Core_Model_App->run(Array)

#14 /var/www/magento/index.php(80): Mage::run('', 'store')

#15 {main}";s:3:"url";s:1:"/";s:11:"script_name";s:10:"/index.php";}
Jeremy Davis's picture

Not sure...

I just tested it and it all seemed to work ok to me (Magento Micro instance launched from Hub). However it wouldn't let me log into the admin account. I'm assuming that must have been because of a typo when I launched it or something...?

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)