Greg's picture

I have installed turnkey phpnuke and all went well, but when I try to login to the admin page with the username and pw I created, it returns to the login page and does not login to the admin console.  I have reinstalled several times, and also manually changed the password in myphpadmin.

Forum: 
Jeremy Davis's picture

Is this a VM (under VirtualBox/VMware or similar) or some other platform (OVZ/LXC/etc) or on bare metal?

I will test an OVZ instance on my Proxmox host to see if I can recreate the issue.

Greg's picture

This is a VM on VMware

Jeremy Davis's picture

I have just spent a bit of time mucking around with phpNuke and I can't get it to work either... :(

Here is some other stuff I tried:

  • rerunning the TKL initscripts (using a very simple password and again with a much more complex password - double checking that i entered and used the correct password; testing for password complexity requirements).
  • editing/resetting the admin user password (MySQL - in the 'nuke_authors' table)
  • manually adding the admin user to MySQL 'nuke_users' table (should work without it, but thought it worth a shot)
  • deleting the existing admin user altogether (the 'nuke_authors' table, which should make phpNuke itself ask for new admin user credentials)

And none of these steps work... :(

Now that I have deleted the admin user I am stuck in the same loop except trying to add an admin user...

Further troubleshooting steps I've tried:

  • changing the phpNuke DB user password (to double check that it is not a DB connection issue - it's not!)
  • granting ownership of the whole /var/www file & directory tree to www-data (to check that it isn't a file/directory permissions issue - it's not!)

So I've run out of ideas... The only thing that I can think of is that there is actually something broken in the version of phpNuke that TurnKey Linux has installed...

FWIW I have lodged a bug on the issue tracker.

Greg's picture

Hopefully there will be a fix.  TurnKey is exactly what I am looking for. 

Jeremy Davis's picture

And despite my best efforts I came up (pretty much) blank... :(

As I posted on the issue (on GitHub):

Further research suggests that this is a common phpNuke issue, with numerous causes (and thus numerous solutions - depending on the specific cause...). After spending some time on it I am no closer to discovering the issue... I'm not sure where to go with this next...

I found 50 something threads that relate to this login loop issue and none of the things I tried (such as adjusting the server time, deleting the existing admin user from the DB, adjusting PHP error reporting level and so on...) resolved it.

Unfortunately I can't justify spending any more time on it ATM. I think that the next step would probably be for me to just look at the TKLDev source and update it to the latest version of phpNuke and again...

FWIW perhaps it is worth you considering one of the alternatives in the meantime (even if just for evaluation)? TurnKey Linux also has XOOPS (which from my reading forked from phpNuke many years ago). There are also many other CMS available - some obviously more relevant than others depending on your usage requirements.

fredooweb's picture

Hy,

I've just resolved the same problem.

Like you, I didn't find any issue on the web; the basic given issue  is to ensure that cookies are accepted; of course they are.

So I spend a couple of hours in php doc, and in phpnuke code too, to resove it, grrrrrrrrrrr

Here's the solution that works for me; just add or replace the existing directive in the php.ini file :

request_order = "GPC"

That permits to pass the cookies in the global environnement and set the differents variables like $admin, $user, etc...

This solution works with phpnuke 7.5 and 8.1

FYI i'm working locally with Easyphp DevServer-14.1VC9, and I try to maintain an existing web site.

I hope it will help you ;-)

 

 

Jeremy Davis's picture

I will test this out ASAP and see if it is the solution to the TurnKey image's issues.

Regardless, major kudos for trying to help out! People like yourself help make the internet a great place! :)

Jeremy Davis's picture

Thanks anyway for sharing.

I think what we need to do is to pull this appliance from the TurnKey library for now... It appears broken and IMO it's better to not have a specific appliance (phpNuke in this instance) than have a broken one...

Add new comment