Tony Upson's picture

Believe I have found another bug?

Within OTRS SysConfig --> I enabled Spell Checker and it defaults to:

 

/usr/bin/ispell

english

 

1. When I try to click "ABC" within OTRS, it detects an incorrect spelled word, but doesnt offer a correctly spelled word.

2. From Command Line, if I run:

echo "Hello just a tets" | ispell -a -d english

an error is thrown: can't open /usr/lib/ispell/english.hash

I checked in /usr/bin and there is no ispell directory. However, there is an ispell and ispell-wrapper file wihtin /usr/bin/

 

I did a google search and came across the following notification: "The official suggestion is to use aspell instead of ispell. English is no longer a supported language under Mandrake for ispell."

So, what should I do here to get spell check to work?

 

 

Forum: 
Tags: 
Tony Upson's picture

It appears the ispell english.hash isn't even installed properly?

How do I address this? Even on a fresh ISO install, this is like this.

 

 

 

- Tony

Network Engineer

Federal Gov't

Tony Upson's picture

bump...

- Tony

Network Engineer

Federal Gov't

Jeremy Davis's picture

It is not uncommon for TurnKey server to not have optional features installed/enabled. Having said that it's probably worth installing...

I'd try

apt-get update && apt-get install ispell
Jeremy Davis's picture

I just had a quick look at the plan and noticed that ispell should already be installed.

According to the file list from the Debian package shows that it should provide /usr/bin/ispell

Tony Upson's picture

As you see in my previous posts, there is no ispell folder within /usr/bin/. the only thing within /usr/bin/ is an ispell and ispell-wrapper file without an extension (also listed above)

 

Should i try to run that apt-get installer you mentioned?

- Tony

Network Engineer

Federal Gov't

Jeremy Davis's picture

According to the FHS /usr/bin is meant to contain binaries only so I would expect it to just contain the binary file (essentially equivalent to a Windows exe).

That still doesn't explain why it doesn't work though...

Tony Upson's picture

attempted to install and it does indicate its already nistalled, however, as you also see from my screen shots, its not working 

- Tony

Network Engineer

Federal Gov't

Jeremy Davis's picture

From what I can gather, enabling spell checker is a 2 step process. You need to enable it and also set the language. TBH that sounds a little weird; especially as the appliance has only American English installed by default. I note that one page I found state that British English is the default.

I also found someone suggesting to disable it and just use your web browsers built in spell check! :)

Tony Upson's picture

how do you use the browser defaults? the red line shows up, but there isnt a suggestion option.

- Tony

Network Engineer

Federal Gov't

Jeremy Davis's picture

Under both Chrome & Firefox (the 2 browsers I use) I just right click on the red underlined word and it gives me suggestions (at the top of th right click menu).
Tony Upson's picture

hmm, is there a setting I need to turn on? I tried firefox and chrome and I receive the following:

 

I did however get Internet Explorer to suggest other options.

- Tony

Network Engineer

Federal Gov't

Tony Upson's picture

it appears that spell check works in fields above the body section, but doesnt work in the body section

 

- Tony

Network Engineer

Federal Gov't

Tony Upson's picture

holding down the control key while right-clicking the misspelled word resolves the issue in Chrome/Firefox for the body section of the ticket.

- Tony

Network Engineer

Federal Gov't

Jeremy Davis's picture

As I just mentioned on another thread it is great info for other users! :)
1ere-Page.fr's picture

Press CTRL + Right Click : to see iSpell Windows (dictionary words)
 

Add new comment