ilia's picture

I am trying to install a clean template for gitlab. 16.1
but after installing  i have the following issues :
i had to enable root ssh login :

sudo sed -i 's/#PermitRootLogin prohibit-password/PermitRootLogin yes/' /etc/ssh/sshd_config

sudo systemctl restart ssh

As far as i thought ssh for root should be enabled in this template.


second after entering ssh with root, i have a prompt of configuration\setting initial menu.. and after finished this step,

Then on to the web ui in the browser with user root and the password i set in the initial step, but it gives error 500,

when i change the user\password to wrong name on purpose, it says invalid user or password 

Forum: 
Jeremy Davis's picture

You shouldn't need to enable root login!?! As you note, it should already be pre-enabled! The only thing that occurs to me is perhaps Proxmox is modifying the default? I'm still running Proxmox v6.x and it definitely doesn't do that for me.

As for the 500 error, I recall having heaps of issues with GitLab. The most common cause of that is lack of resources. IIRC it needs at least 4GB RAM and 2 CPU cores. If you're still having issues, TBH I'm not sure. But you could try reinstalling it. I.e.:

apt update
apt purge gitlab-ce -y
apt install gitlab-ce -y
ilia's picture

i tried it did not help,
eventually i fixed it with the commands: (i found elsewhere don't remember were)
i am based on proxmox 7.1

 

fix error 500 on login
sudo gitlab-rails c
settings = ApplicationSetting.last
settings.update_column(:runners_registration_token_encrypted, nil)
settings.update_column(:encrypted_ci_jwt_signing_key, nil)
settings.save!
q

 

the host have 16GB ram and 8 cores 
 

Jeremy Davis's picture

Yes, those specs should run GitLab fine! Still, it's the most common issue, so I had to mention it...

Thanks heaps for posting back with your solution. I'm sure that will be a help to others.

Add new comment