Jeremy Davis's picture

I just got this warning when I tried to post today. I've been getting some similar errors all day today, both on my old (Ubuntu 9.10) Laptop and my Ubuntu 10.04 desktop (both running Firefox 3.5.x, not sure of java versions). It seems to happen that sometimes (and it seems almost random) that when editing, you click the save button and nothing happens. Sometimes you can push the button again and after a brief hesitation it will work. But occasionally it will go to a similar error. I have had a few that I have just tried again from a new tab and its worked, but some refuse to save and just keep coming back with the message :

Your hashcash string is not valid.

Please try "Hard-refreshing" this page (Most users should press Ctrl-F5)

Logging out and back seems to be the only solution when a page does that a couple of times (it keeps doing it, but other pages continue to be fine)

[update] I seem to be having ongoing issues trying to add a tag to the two threads here and here.

Liraz Siri's picture

Do you use any special extensions that mess around with Javascript execution? (e.g., NoScript).

Looking at the logs this doesn't seem to be a frequent problem. I suspect this might have been caused by your browser caching the non-hashcash versions of the pages, in which case clearing the case would have resolved it. If the problem still persisted after the initial problems that could be a warning sign something is seriously wrong.

For now I've disabled Hashcash.

Jeremy Davis's picture

Thanks for the follow up though. Yes it's been mostly fine for a while now, it resolved itself later the same day from memory (or very soon after anyway).

But for the record I was using Firefox 3.5/6.something (Ubuntu 10.04) and with lots of extensions but no NoScript (I only bother using it under Windows). But I also had the same issues using Chromium (don't recall what version but its the unstable PPA - no extensions or addons, etc). I'm not sure if it was a factor but I have a habit of having 30-40 plus tabs/windows open.

Since it seemed to mostly resolve itself this has only happened a couple of times and I've noticed that if I click preview again (after I get the hashcash error) then it will all work ok.

Bottom line is it seems fine now, haven't had any problems for a few days at least.

Liraz Siri's picture

I'll keep it disabled for now, for simplicity's sake. Sounds like it was just a caching issue, but anyhow according to the logs, Hashcash isn't really necessary at the moment as the other countermeasures are working well enough. If Mollom gets unreliable again I'll reactivate it.
Jiger's picture

Hi mate,

I am trying to post my reply from last 20 hours however not able to b'cos of the same error "Your hashcash string is not valid.

Please try "Hard-refreshing" this page (Most users should press Ctrl-F5)"


Can somebody take care of this at the earliest, Thanks.




Jeremy Davis's picture

But with perseverence it usually works...

I've tried three different browsers with multiple different configurations, disabling noscript and everything else i can think of... here's hoping a comment works when a new post won't?

Jeremy Davis's picture

So you will now avoid most of the spam traps. Please let me know if you continue to have issues (or they reoccur for you).

That also applies to anyone else having issues. Just ping me and I can do this for anyone (who is a legitimate poster - spammers, please don't even ask - any accounts spamming the forums are instantly deleted).

Disorganise's picture

Don't know if this will post...

Just created a forum user to get support for wordpress but get this hashcash error when trying to create the post.  Tried firefox and chrome.  logged out and in.


Jeremy Davis's picture

So now, you too can now avoid the spam traps! :)

Disorganise's picture

thanks heaps :)

kaktux's picture

same here - i tried with my normal - extension using - browser firefox.

But the same problem occurs with extension free chromium (i use ubuntu lts).

If you can read this it goes for new posts only - but replies work.

Jeremy Davis's picture

You're in! :) It should all work ok now...

Jeremy Davis's picture

I'm not sure how or why, but this post slipped past me.

Re the hashcash issue, I'm still not clear on what the cause of that is, nor why it seems to affect some users consistently, but not others. Generally, the way that it seems to be best avoided by most users is to create a user account, let me know (email jeremy AT and I can disable the spam traps for your account. Unfortunately, even that doesn't appear to be foolproof as one user has stated that he still occasionally has issues posting, but it seems to be an improvement. When I have my backlog under control, I'll try to put a bit more time and attention into this issue and see if we can improve it without opening the spammer floodgates...

Regarding reporting your issue, we disable issues for the individual repos on purpose as we have a consolidated issue tracker. The reason why we do that, is that because our appliances have such a large footprint of common code, often issues that occur on a specific appliance may actually affect multiple appliances.

With regard to the specific issue you are reporting here, I assume that this is an AWS server? (Only AWS servers should be running the ec2-metadata firstboot script). The IP address should be bonded to all AWS instances and is where the instance metadata is stored and accessible. The error you note suggests that for some reason the metadata service was not available when the appliance was trying to start up. In my experience, that is generally an intermittent AWS infrastructure issue. AFAIK it should only occur on firstboot (at least that's the only time I've hit it, and only a few times in the last ~10 years). Assuming that it's on firstboot, generally just starting a new server will resolve it. If that doesn't do it, try launching a new server in a different availability zone (and/or region if appropriate to your use case).

If the scenario where you're hitting this issue doesn't match what I've posted, please provide additional info and context and I'll try again...

Ape21's picture

For me what worked is disabling the adblocker. Adblocker sometimes force some part of javascript to not function.

Another solution might be, try enabling/allowing the javascript from the settings before surfing the website. If you have javascript disabled and then allow it after surfing the website, it might not work.

So, do it before surfing the website then clearing the history with cache/cookies. Restart your browser and check if it still works.

Add new comment