Andrew Killer's picture

Please see updated thread here


Here is a quick guide on upgrading the base TurnKey Redmine install to the latest version of Redmine (2.0.3 at this moment in time). I tried several methods including using the Redmine PPA but in the end couldn't get anything else to work and I don't have the knowledge (/patience) to fix it myself.

99% of this guide is from Adam Wu/babbomaria's posts, I'm just collating them to make it easier for everyone so pass the credit onto them :).

I was going to use the SVN Redmine version but it was giving me svn: REPORT of '/svn/!svn/vcc/default': Could not parse chunk size ( errors during checkout so switched to Mercurial.


Go Go Go

Whatever you do, take a snapshot of your VM before you do this as I imagine it wouldn't be simple to revert back manually if it went wrong.


Update Rails

TurnKey Redmine ships with rails version 2.3.8, Redmine 2 needs 3.2.6 so update it with:

gem install rails

Test it worked with:

rails -v


Get Redmine

This is pretty much just a copy/paste of [1] mixed with some of the Redmine install notes for the later versions. Some commands will error but just ignore them. If you have rmagick installed remove it from step 11, I don't.

Copy/paste this into a script to make life easy:

  1. cd /var/www
  2. mv railsapp railsapp-old
  3. hg clone --updaterev 2.0-stable railsapp
  4. cp railsapp-old/config/email.yml railsapp/config/configuration.yml
  5. cp railsapp-old/config/database.yml railsapp/config/database.yml
  6. cp -r railsapp-old/files/ railsapp/files/
  7. chown -R root:www-data /var/www/railsapp
  8. cd railsapp
  9. gem install bundler
  10. gem install test-unit
  11. bundle install --without development test rmagick
  12. mkdir public/plugin_assets
  13. rake generate_session_store
  14. rake db:migrate RAILS_ENV=production
  15. chown -R www-data:www-data files log tmp public/plugin_assets
  16. rake db:migrate:upgrade_plugin_migrations RAILS_ENV=production
  17. rake db:migrate_plugins RAILS_ENV=production
  18. chmod -R 755 files log/ tmp/ public/plugin_assets
  19. rake tmp:cache:clear
  20. rake tmp:sessions:clear

Make sure you go to Admin -> Roles & permissions and assign new permissions. Manage related issues was added since the base version at least if not more.


Check it works



Hopefully you'll see something like this:


Redmine version


Ruby version

1.8.7 (i686-linux)

Rails version




Database adapter

Redmine plugins:  

no plugin installed



Upgrading In The Future

By switching to using the Redmine Mercurial repository upgrades in the future should just require the following steps [4]:

  1. cd /var/www/railsapp
  2. rake generate_session_store
  3. hg pull
  4. hg update
  5. bundle install --without development test rmagick
  6. rake db:migrate RAILS_ENV=production
  7. rake redmine:plugins:migrate RAILS_ENV=production
  8. rake tmp:cache:clear
  9. rake tmp:sessions:clear








Mario Luzeiro's picture

Thanks! I will try to follow it.


But I think that in the future, TKL Redmine should be updated and add more features. In Redmine there are lots of features that also need work in the distro (as the version control with login.. auto checkout out version folders.. make an easy upgradable plugins and redmine build.. ) may here the community should help to make a good featured distribution.

Jeremy Davis's picture

But some of your ideas sound interesting Mario. Perhaps flesh your ideas a bit more (with a few more specifics). Maybe lodge a Blueprint or start a new forum thread.

Todd Forsberg's picture

I followed your steps, but the railsapps folders have question marks at the end of the folder name and the system reports "No such file or directory"  Any ideas what I may have done wrong? 

-Todd Forsberg

Andrew Killer's picture

Hi Todd,

Can you post the output from:

ls -l /var/www/

I have no idea where the question marks came from unless it's some odd character encoding problem if you copied/pasted the steps from the forums.

Andrew Killer's picture

Strange. Can you rename it by running:

mv /var/www/railsapp? /var/www/railsapp


You should then be able to carry on if that works.

Todd Forsberg's picture

Yes, I can rename it.  I didn't think of trying that before.  I think you were correct about the chacter encoding.  I did copy/paste from the website.  I'm going to retype it and try again.

-Todd Forsberg

dnepr's picture

Redmine insatllation Ubuntu 12.10, Nginx, php-fpm, MySQL, thin

Jamie's picture

Hi. I wanted to follow these instructions but the railsapp folder is not found under /var/www.  

The only things under there are:



My TK instance has Redmine 1.4.4.stable currently.

Any help would be great.

Andrew Killer's picture

It sounds like you have a later version of the Redmine TurnKey release than what I used.

Could you try all the steps within the redmine folder instead?

Jamie's picture

Hey. Ya, you're right.  I downloaded version 11.3 and the structure matched.  I also ran into the issue about mysql version mentioned and solved in the comments.  So, as it stands now, I have 2.0.4 running :)


Thanks for responding so fast and thanks for posting this article in the first place!  Much appreciated.  

Have a good one


Andrew Killer's picture

No problem; glad you got it working :). I'm sure it wouldn't be too difficult to get it to work on the latest version of TurnKey if you needed any of the new things it has - now's the time before you start using it!

With a couple of people having the MySQL problem recently I wonder if there's been an update to one of the apt packages or something which is causing the new MySQL version to be installed.

Though saying that, my own install hasn't installed the other MySQL version. I've just pulled the latest Redmine version using my update script (see the commands in Upgrading In The Future) and it's still not installed.

Very odd!

Jamie's picture

Hey again.

I retried this with the latest release (12.0) and it worked. Just had to change railsapp to redmine (in the steps).  Step 16 fails but can be skipped anyway and it all works fine.  Thanks again! 

Jeremy Davis's picture

Uses a package from the repo (rather than upstream). But I'm only guessing....

Jamie's picture

Hey.  I tried version 12 now and applied the steps based on the Redmine folder (vs railsapp).  Step 16 failed and can be skipped but otherwise it worked a charm :)  Thanks again!

On a side, im trying to setup the git repo to align with the redmine users and want the access secured.  Can you recommend any good resource for this?  I've been scouring.

Todd Forsberg's picture

 I retyped the whole thing.  Same results. 

But, but just typing each line manually in the "Shell-in-box" console, it worked fine.   There are some depricated items in above listing (script), but Ruby provided the new methods to use.

-Todd Forsberg

John K's picture

Andrew -

First off, THANKS FOR THE GUIDE! I was able to run this on my previously upgraded install which was at 1.3 before starting. As Todd said, there are two depricated steps but the new methods are provided when attempting to run them (#13 and #17).

I did have one error I was not able to track down. When running #16 to upgrade_plugin_migrations, I get: aborted. Don't know how to build task rake db:migrate:upgrade_plugin_migrations

I wonder if it's OK in my situation (don't have any plugins installed). Is that error BECAUSE I have no plugins? Should I be worried about this error? Is it indicative of the upgrade not going well? Will it blow up in my face later? :) 

I have been able to get into the Redmine interface and at first glance it SEEMS OK.

Thanks in advance for any words of wisdom and thanks again for posting this!  

Andrew Killer's picture

Hi John,

That's odd. I ran the whole upgrade procedure a couple of times on different VMs and never saw that error, maybe it was because I was upgrading from the stock version not 1.3.

The Redmine upgrade docs do list a different command to upgrade the plugins database, this may be worth a try instead:

rake redmine:plugins:migrate RAILS_ENV=production 

If you look at the Upgrading In The Future part of my original post that's actually the one I used in there. Try running the upgrade commands from there and see if it works too - I dropped them into a script which I can periodically run to kee it up to date.

Failing that, I would say as long as everything appears to work then just ignore it, it sounds like it's working fine!



John K's picture

I did as you suggested and it didn't generate any visible errors to console. Assuming that

rake redmine:plugins:migrate RAILS_ENV=production

is equivalent to

rake db:migrate:upgrade_plugin_migrations RAILS_ENV=production

then I should be all set.


Cyrille's picture


All update operations runned fine, with blog comment correction.

But at the first application start, an Exception is throwing:

*** Exception NoMethodError in PhusionPassenger::Rack::ApplicationSpawner (undefined method `session=' for ActionController::Base:Class) (process 1283):
    from /usr/local/lib/ruby/gems/1.8/gems/actionpack-3.2.6/lib/action_controller/railtie.rb:41:in `send'
    from /usr/local/lib/ruby/gems/1.8/gems/actionpack-3.2.6/lib/action_controller/railtie.rb:41
Cyrille's picture

After the update the script/about was running fine, but after trying to run redmine with the webbrowser, now the script/about is throwing the same exception.

Cyrille's picture

I've found the problem: a file "config/additional_environment.rb" was generated some time.

# rm config/additional_environment.rb

then all stuffs work ;-)

I just do not know when this file was generated...

Oliver's picture


first of all, thanks for this perfect description. My problem now is, that the plugins are not copied to the right directory. Did this by hand and called 
rake redmine:plugins_migrade
I received the following error
undefined local variable or method 'config' for main:Object
The result of
rake redmine:plugins_migrade --trace
** Invoke redmine:plugins:migrate (first_time)                                                                                         ** Invoke environment (first_time)                                                                                                           ** Execute environment                                                                                                                           rake aborted!                                                                                                                                                                                 

undefined local variable or method `config' for main:Object                                                                                                                                   


/usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `require'                                                                                     

/usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `require'                                                                                     

/usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:236:in `load_dependency'                                                                             

/usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `require'                                                                                     

/var/www/railsapp/lib/redmine/plugin.rb:130:in `load'                                                                                                                                         

/var/www/railsapp/lib/redmine/plugin.rb:121:in `each'                                                                                                                                         

/var/www/railsapp/lib/redmine/plugin.rb:121:in `load'                                                                                                                                         


/usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:245:in `load'                                                                                        

/usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:245:in `load'                                                                                        

/usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:236:in `load_dependency'                                                                             

/usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:245:in `load'                                                                                        


/usr/local/lib/ruby/gems/1.8/gems/railties-3.2.6/lib/rails/engine.rb:587:in `each'                                                                                                            


/usr/local/lib/ruby/gems/1.8/gems/railties-3.2.6/lib/rails/initializable.rb:30:in `instance_exec'                                                                                             

/usr/local/lib/ruby/gems/1.8/gems/railties-3.2.6/lib/rails/initializable.rb:30:in `run'                                                                                                       

/usr/local/lib/ruby/gems/1.8/gems/railties-3.2.6/lib/rails/initializable.rb:55:in `run_initializers'                                                                                          

/usr/local/lib/ruby/gems/1.8/gems/railties-3.2.6/lib/rails/initializable.rb:54:in `each'                                                                                                      

/usr/local/lib/ruby/gems/1.8/gems/railties-3.2.6/lib/rails/initializable.rb:54:in `run_initializers'                                                                                          

/usr/local/lib/ruby/gems/1.8/gems/railties-3.2.6/lib/rails/application.rb:136:in `initialize!'                                                                                                

/usr/local/lib/ruby/gems/1.8/gems/railties-3.2.6/lib/rails/railtie/configurable.rb:30:in `send'                                                                                               

/usr/local/lib/ruby/gems/1.8/gems/railties-3.2.6/lib/rails/railtie/configurable.rb:30:in `method_missing'                                                                                     


/usr/local/lib/ruby/gems/1.8/gems/railties-3.2.6/lib/rails/application.rb:103:in `require'                                                                                                    

/usr/local/lib/ruby/gems/1.8/gems/railties-3.2.6/lib/rails/application.rb:103:in `require_environment!'                                                                                       

/usr/local/lib/ruby/gems/1.8/gems/railties-3.2.6/lib/rails/application.rb:292:in `initialize_tasks'                                                                                           

/usr/local/lib/ruby/gems/1.8/gems/rake- `call'                                                                                                                 

/usr/local/lib/ruby/gems/1.8/gems/rake- `execute'                                                                                                              

/usr/local/lib/ruby/gems/1.8/gems/rake- `each'                                                                                                                 

/usr/local/lib/ruby/gems/1.8/gems/rake- `execute'                                                                                                              

/usr/local/lib/ruby/gems/1.8/gems/rake- `invoke_with_call_chain'                                                                                               

/usr/local/lib/ruby/1.8/monitor.rb:242:in `synchronize'                                                                                                                                       

/usr/local/lib/ruby/gems/1.8/gems/rake- `invoke_with_call_chain'                                                                                               

/usr/local/lib/ruby/gems/1.8/gems/rake- `invoke_prerequisites'                                                                                                 

/usr/local/lib/ruby/gems/1.8/gems/rake- `each'                                                                                                                 

/usr/local/lib/ruby/gems/1.8/gems/rake- `invoke_prerequisites'                                                                                                 

/usr/local/lib/ruby/gems/1.8/gems/rake- `invoke_with_call_chain'                                                                                               

/usr/local/lib/ruby/1.8/monitor.rb:242:in `synchronize'                                                                                                                                       

/usr/local/lib/ruby/gems/1.8/gems/rake- `invoke_with_call_chain'                                                                                               

/usr/local/lib/ruby/gems/1.8/gems/rake- `invoke'                                                                                                               

/usr/local/lib/ruby/gems/1.8/gems/rake- `invoke_task'                                                                                                   

/usr/local/lib/ruby/gems/1.8/gems/rake- `top_level'                                                                                                      

/usr/local/lib/ruby/gems/1.8/gems/rake- `each'                                                                                                           

/usr/local/lib/ruby/gems/1.8/gems/rake- `top_level'                                                                                                      

/usr/local/lib/ruby/gems/1.8/gems/rake- `standard_exception_handling'                                                                                   

/usr/local/lib/ruby/gems/1.8/gems/rake- `top_level'                                                                                                      

/usr/local/lib/ruby/gems/1.8/gems/rake- `run'                                                                                                            

/usr/local/lib/ruby/gems/1.8/gems/rake- `standard_exception_handling'                                                                                   

/usr/local/lib/ruby/gems/1.8/gems/rake- `run'                                                                                                            


/usr/local/bin/rake:19:in `load'                                                                                                                                                              


Tasks: TOP => redmine:plugins:migrate => environment
Can anyone help me!
Andrew Killer's picture

Hmm I'm not too sure. Did you definately run the below command with RAILS_ENV=production at the end?

rake db:migrate_plugins RAILS_ENV=production


Faililng that seems to have a similar problem to you - look through the comments.

Apart from that I'd look to post on the official Redmine support forums - I don't know Ruby personally so wouldn't know where to begin.


Chris B.'s picture

Just to share my experience : after days searching a clean way to upgrade Redmine I found your guide.

So just, disabled all the old plugins, followed your how-to (except for 16., ran "rake redmine:plugins:migrate RAILS_ENV=production" instead ) and it was all done !!


Thanks A LOT for this tutorial.

L. Arnold's picture

I posted separately on TKL Forums a request for guidance on upgrading the Tracks Appliance which also runs on Rails:

It seems the subject is quite similar to this.  The new Debian Tracks will not upgrade with a simply TKLBAM-RESTORE so I assume I need to get my Tracks intsall up to 2.1 and then run a TKLBAM-RESTORE to jump into v 12 TKL (this was my method for Magento anyway). 

I am completely ohterwise out of my element with RAILS and would love some guidance.  These links tell me what to do, but I want to contextualize to a TKL install.

Any guidance someone could offer?

Thank you.

mbeck's picture

i am not able to pass step 14 and getting the error

root@redminetest www/railsapp# rake db:migrate RAILS_ENV=production
rake aborted!
Please install the mysql adapter: `gem install activerecord-mysql-adapter` (can't activate mysql (~> 2.8.1, runtime), already activated mysql-2.9.0. Make sure all dependencies are added to Gemfile.)
/var/www/railsapp/config/initializers/00-core_plugins.rb:2:in `each'
Tasks: TOP => db:migrate => environment
(See full trace by running task with --trace)


any help or where i can look.  i did ran gem install activerecord-mysql-adapter without issues but still this step is not running suvessfully. my gem list shows

mysql (2.9.0, 2.8.1)

and the database.yml has the following lines

  adapter: mysql

what could be the reason

Andrew Killer's picture

Mine only shows as having mysql 2.8.1 installed so personally I'd try removing one of those versions and see what happens:

gem uninstall mysql --version 2.8.1
(and if that fails try 2.9.0 I guess)

Good luck!

mbeck's picture

thankx for your clue.

This one helped finally

gem install -v=2.8.1 mysql
gem uninstall -v=2.9.0 mysql
IN Gemfile of RM modify gem "mysql" to gem "mysql" , "2.8.1"

Andrew Killer's picture

Glad you got it sorted!

Cheers for posting the solution. There's nothing worse than finding your exact problem from a Google search and someone doesn't tell you how they fixed it.

Don's picture

Error message:
undefined local variable or method `config' for main:Object
Exception class:
Application root:
/var/www/redmine-2.2.2 [Yes, I did change the directory. It's changed in the apache config of webmin, etc.]
Any ideas what this error is? I can't seem to track it down. Here is the full backtrace.
0 /var/www/redmine-2.2.2/plugins/engines/init.rb 3  
1 /usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.11/lib/active_support/dependencies.rb 251 in `require'
2 /usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.11/lib/active_support/dependencies.rb 251 in `require'
3 /usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.11/lib/active_support/dependencies.rb 236 in `load_dependency'
4 /usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.11/lib/active_support/dependencies.rb 251 in `require'
5 /var/www/redmine-2.2.2/lib/redmine/plugin.rb 130 in `load'
6 /var/www/redmine-2.2.2/lib/redmine/plugin.rb 121 in `each'
7 /var/www/redmine-2.2.2/lib/redmine/plugin.rb 121 in `load'
8 /var/www/redmine-2.2.2/config/initializers/30-redmine.rb 12  
9 /usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.11/lib/active_support/dependencies.rb 245 in `load'
10 /usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.11/lib/active_support/dependencies.rb 245 in `load'
11 /usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.11/lib/active_support/dependencies.rb 236 in `load_dependency'
12 /usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.11/lib/active_support/dependencies.rb 245 in `load'
13 /usr/local/lib/ruby/gems/1.8/gems/railties-3.2.11/lib/rails/engine.rb 588  
14 /usr/local/lib/ruby/gems/1.8/gems/railties-3.2.11/lib/rails/engine.rb 587 in `each'
15 /usr/local/lib/ruby/gems/1.8/gems/railties-3.2.11/lib/rails/engine.rb 587  
16 /usr/local/lib/ruby/gems/1.8/gems/railties-3.2.11/lib/rails/initializable.rb 30 in `instance_exec'
17 /usr/local/lib/ruby/gems/1.8/gems/railties-3.2.11/lib/rails/initializable.rb 30 in `run'
18 /usr/local/lib/ruby/gems/1.8/gems/railties-3.2.11/lib/rails/initializable.rb 55 in `run_initializers'
19 /usr/local/lib/ruby/gems/1.8/gems/railties-3.2.11/lib/rails/initializable.rb 54 in `each'
20 /usr/local/lib/ruby/gems/1.8/gems/railties-3.2.11/lib/rails/initializable.rb 54 in `run_initializers'
21 /usr/local/lib/ruby/gems/1.8/gems/railties-3.2.11/lib/rails/application.rb 136 in `initialize!'
22 /usr/local/lib/ruby/gems/1.8/gems/railties-3.2.11/lib/rails/railtie/configurable.rb 30 in `send'
23 /usr/local/lib/ruby/gems/1.8/gems/railties-3.2.11/lib/rails/railtie/configurable.rb 30 in `method_missing'
24 /var/www/redmine-2.2.2/config/environment.rb 14  
25 3 in `require'
26 3  
27 /usr/local/lib/ruby/gems/1.8/gems/rack-1.4.4/lib/rack/builder.rb 51 in `instance_eval'
28 /usr/local/lib/ruby/gems/1.8/gems/rack-1.4.4/lib/rack/builder.rb 51 in `initialize'
29 1 in `new'

Andrew Killer's picture

Looks like you're missing a file.

Have a look at which should get you going again.

Don's picture

But it wasn't.

Copied the from /var/www/railsapp/vendor/rails/railties/dispatches/ as listed in your link above.

root@redmine www/redmine-2.2.2# locate

Contents of the file looks like the one in the link.

# Rack Dispatcher

# Require your environment file to bootstrap Rails
require File.dirname(__FILE__) + '/config/environment'

# Dispatch the request

Still get the same error message.

The only other thing I've noticed ... when editing the files in vi, seems the EOL is showing as ^M - which from previous experince doesn't usually end well. Might it be worth my time to strip those out?

Andrew Killer's picture

I'm sure removing ^M wouldn't hurt it (apparently it's a DOS/Windows leftover).

I wonder, on my install my plugins directory is empty (bar the README file).

What happens if you clear out your plugins directory? Looking at it in a bit more detail it's throwing the exception trying to read from the plugin folder so that should be a good start.

Don's picture

I've got to learn how to dechiper those error messages better.

That was the issue. Up and running now. Odd part is I knew not to have plugins there, but I guess I never went back to make sure it was 100% cleared.

Andrew Killer's picture

Glad it's working :).

It's not the easiest stacktrace to read to be honest, but then again I don't know Ruby or how it works.

Graham Stewart's picture

If you are upgrading from 1.2 - 4 to 2.2 or greater using these instructions or those provided by redmine, then take care as the versions of ruby and rails have moved forward. gem install rails will try to install rails 4, which requires ruby 1.9.3 but a new ruby install gets you 2.0.0. The latest versions of redmine require rails 3.2.13 and will not work with rails 4.0.

Specifying the actual versions with the ruby and rails installs may help. I now have a broken redmine appliance because I have not been able to downgrade successfully. The vm is backedup and so is the data so no problems except for the wasted time.

It is probably better to download a new redmine appliance and transfer the data.


waspinator's picture

I tried following the instructions for option 2 here:

and running

svn update

but it doesn't seem to do anything. just says

Skipped '.'

Bundle update runs and seems to do something, but I'm still on version 2.2.3

Trying 'option 1' in the guide gives me a 500 error page.


Andrew Killer's picture

Is your current Redmine copy checked out from SVN? It sounds like it's not.

Option 1 from that guide may be better for you in that case.

waspinator's picture

not sure. whatever was included in the Turnkey 13.0 version.

I tried option 1 after trying option 2, so maybe that's what broke it.

cepope's picture

The piece I had to figure out is after the install apache has to be restarted for the new redmine version to take affect:

service apache2 restart

Dominik's picture

Hello Folks,

I would like to know if this guide is actually still up to date or is there a newer version and if so where can I find it? 


Thanks in advance :)



Andrew Killer's picture

I've not updated it for a long time but it should still mostly work.

The only caveat is that you can't checkout past revision f0d7c701cd6f0e9e7bcdf021607c0445a158d13f (13102) without gettings lots of errors due to incorrect rails/rake versions (I forget which). These versions weren't available via apt so I gave up :).

Replacing the update command with hg update -r 13102 should work.

Dominik's picture

Okay Ill try it.


Thanks !

Andrew Killer's picture

If you have to change any of the steps it would be worth posting what they were here so others may benefit.

We're still running this VM for all our source without issues though :).

dsudo's picture


after 2 days of researching and error solving I finally updated the redmine from v1.4.4 to 2.6.0.

It took me a while to figure out what was missing and what needs to be updated in order to make it work.

I will work now on a detailled documentation including ruby/rails update with rvm, installing passenger and mysql2 and also editing files which essential to have a full working redmine. Once I finish the docu I will post it here.

Thanks for this guide though, it helped me out a lot.

With best regards



Jeremy Davis's picture

This thread is getting pretty old (and lengthy) now so it may even be worth starting a new thread? Regardless, looking forward to your updated doc, it will be a great help to the community! Great work! :)
khaledmu's picture


Add new comment